1999 S500 Grand Edition.. Just a few troubles - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-22-2012, 08:37 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2012
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation 1999 S500 Grand Edition.. Just a few troubles

Hey Guys!!

I am now the VERY VERY Proud owner of a 1999 S500 Grand Edition!! I couldn't be happier if you gave me a million Dollars... ok, that was a slight exageration.. Anywho.. I purchased it from a really nice guy about 2 weeks ago in Brooklyn and I absolutely LOVE the car but I do have a couple of questions and need your help.

The things that are wrong with ther car are as follows in order of severity:

1: The ASR BAS light comes on SOMETIMES and I really wouldn't care, but it affects the operation of the cruise control when it does.. Sometimes I can drive 50 miles and it won't come on.. then I might drive 100 ft and it comes on.. haven't been able to put my finger definitively on any particular cause although it does seem that normally I have to press the brake pedal for it to happen as I performed a little experiment the other day. I was on a stretch of highway and Pulled off to reset the ASR light before getting back on. I then took off down the highway, and didn't press the brake for around 70 miles and the ASR/BAS stayed off. Just as soon as I had to tap the brakes BOOM!!! ASR LIGHT!! I read somewhere here that the switch may be the culprit for this as well. Also it seems to happen more frequently after the car is hot and less when it has just been started or has cooled off for a while..

2: I need new outside mirrors, two days before I was to pick it up someone stole the passenger side one and broke the drivers side partially..

3: Now this has only happened 2 times and it was really strange.. Jst as the temperature reached around 101 the speedometer dropped to zero and the transmission stopped shifting. Not limp home mode where it only does 2nd gear, this was just whatever the last gear was, it left it there. I am wondering if there is a circuit breaker or a relay somewhere that could cause this? I don't think it was the speedometer sensor as when I pulled over and turned off and back on everything was normal on both instances... Very strange indeed.

4: The check engine light is on.. The guy has replaced the Mass airflow sensor, the plugs, some coils alot of parts that I have the old parts for. I have to get the code read before I talk about this too much i suppose, he said it was for misfire, but she runs like a top (no shaking stumbling or hesitation) and I'm getting about 22-24 on the highway with the ac running not that that makes a terrible amount of difference anyway. I can reset the codes (unplug the battery, I know this is a bad method :-) ) and drive the car around a hundred miles before it ever comes back on.. one day it went off by itself and then a few days later came back. We will check this one out in greater depth later.

7: The transmission has about 100k on the rebuild... I don't like that there is a sealed tranny, no dipstick thing.. This worries me.. I have to get the dipstick "tool".

7: The doorsill Illumination for the front doesn't work.. the inverters are bad.. the rear does, but the front no. Where are they located!??!?! I can't find them.

That's about it.. everything else works perfectly!!! oh well The remote is broken, but I spoke to Benz and a remote key (switchblade type is 187) may wait a while on that is there any other place to get an uncut switchblade remote key for less??.

So guys.. the car has 190k and drives like a champ I paid 3k even for it.. It has a few scratches and I'm going to get her repainted.. after I get the other things done.. the grand edition Obsidian Black of course.

Thanks for all help guys!!
Leron

1999 Mercedes S500 Grand Edition
1985 VW Vanagon Weekender
1975 Mercedes 240D
1971 VW Type II Weekender

Last edited by Leron; 07-22-2012 at 08:39 AM.
Leron is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-22-2012, 03:31 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
My advice is to ask your questions on the W140 forum. Just scroll down from this general one and look in the sedans section.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 4 (permalink) Old 07-23-2012, 04:52 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2012
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Musikmann View Post
My advice is to ask your questions on the W140 forum. Just scroll down from this general one and look in the sedans section.
Thanks Musik... I am new here, my very first post.. I'll copy it there.

Leron
Leron is offline  
post #4 of 4 (permalink) Old 07-23-2012, 08:28 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by Leron View Post
Thanks Musik... I am new here, my very first post.. I'll copy it there. Leron
I noticed you are new. A lot of newbies start out on the general forum and just need some directions to the proper place. Good luck with your nice W140.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome