Hi from Vicki - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-21-2012, 06:17 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Vehicle: 1992 300SL, 1993 S320, 1993 S500 coupe
Location: Gold Coast, Australia
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hi from Vicki

Hello everyone. I search this site religiously whenever I have a problem. I have a 92 300SL (my baby), a 93 400SEL, a 93 S320 and very soon (picking up today) a 96 S320 (stuck in limp mode). The S class cars collectively have a multitude of problems. Through the exceptionally knowledgeable people on this site, we have managed to self-diagnose and fix some of the problems, including the central locking not working on the 400SEL. That was simply a fuse! Amazing. I'm now looking at buying a Star diagnosis system but I will search the threads on what to get, where from etc.

Thank you everyone for your wealth of knowledge. It is so appreciated.
temporarynzer is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-21-2012, 11:28 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Vehicle: 1992 300SL, 1993 S320, 1993 S500 coupe
Location: Gold Coast, Australia
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The new S320

Hi again. OK, got my new baby home today and been searching this site all afternoon to find some answers. Engine is stuck in second gear limp mode, which I have learned is the more serious limp mode to be in. The previous owner has had it checked by several mechanics and no codes found. He gets it reset for $100 a pop and it is fine for a month and goes back into limp mode. No CEL on. We are going to try a few things first that I have read on this site before taking it for a diagnostic.

Also, the rear interior lights won't turn off. I didn't check the doors as we disconnected the battery once we got it home. But I did notice the three lights above the back seat were on and would not turn off when manually pressing the button. She's got two broken head lights and the emblem has been pulled off (vandalism - how can anyone do that!)

Got the 400SEL booked in for diagnostics tomorrow, which has a few issues. Hopefully nothing major, and things we can fix ourselves.
temporarynzer is offline  
post #3 of 6 (permalink) Old 07-21-2012, 11:33 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Vehicle: 1992 300SL, 1993 S320, 1993 S500 coupe
Location: Gold Coast, Australia
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Photo

Trying to upload a photo
Attached Thumbnails
Click image for larger version

Name:	mercs.jpg
Views:	42
Size:	58.1 KB
ID:	457708  
temporarynzer is offline  
post #4 of 6 (permalink) Old 07-21-2012, 11:41 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Vehicle: 1992 300SL, 1993 S320, 1993 S500 coupe
Location: Gold Coast, Australia
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
My 300SL

This is my baby
Attached Thumbnails
Click image for larger version

Name:	mercs2.jpg
Views:	36
Size:	95.7 KB
ID:	457710  
temporarynzer is offline  
post #5 of 6 (permalink) Old 07-23-2012, 04:57 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 289 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #6 of 6 (permalink) Old 07-23-2012, 08:13 AM
BenzWorld Extremist
 
galaxys's Avatar
 
Date registered: Nov 2008
Vehicle: 2011 SLK300 Plutonium Silver (2002 SLK230 Sold)
Location: Las Vegas
Posts: 993
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Enjoy the nice ride and the forum!

galaxys is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome