no ignition. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-19-2012, 09:08 AM Thread Starter
BenzWorld Junior Member
Date registered: Jul 2012
Posts: 29
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
no ignition.

hi all could anyone help?

2002 cdi e320 estate,been fine and doing what it should,however, i got in the car last saturday night after a gig(i'm a vocalist) and with my kit loaded up started her up as normal, pulled off of the small kerb i'd parked on and the engine cut out,tried to restart,nothing,tried park and neutral,nothing.
eventually got the car recovered to my house thinking it would be something simple had come loose upon dropping off the kerb that i could fix the next day.
i've had the car stripped and cannot find one loose connection,and it still wont start.
some other symptoms that may help to diagnose are:
key IS accepted and turns to position 3 but without cranking the starter.
no audible click from the starter so thats not jammed.
the glow plug light DOES NOT illuminate.
the rear lights come on with the ignition switch being turned on.
the front two fans under the bonnet(not sure if they're the cooling fans or air con fans)come on at a slow speed with the ignition on (key position 2)
the blower fan inside the cabin blows gently even if the switch is off.

its as though the immobiliser is on, or the car thinks its in drive and will not start.
or as if there is a short somewhere causing the electrical gremlins( fans and lights etc)
if anyone would know where the most likely causes are i'd really appreciate some help,as i'm at a loss.
our lovely summer weather isnt helping either!

oh and before i forget, the abs/tracking light has been coming on recently, before this ignition failure,and saying visit the workshop,then clears when the car was switched off and restarted.

thanks in advance.
neutronstar64 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome