99 ml 320 missfire - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-15-2012, 08:47 AM Thread Starter
BenzWorld Newbie
Date registered: Jul 2012
Vehicle: 99 ml320
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
99 ml 320 missfire

Hi guys iv a 99 ml320 with lpg conversion, iv recently got a missfire while running on petrol I read the ecu got codes p0300, p0304, p0305 & p0306, when I disconnect the coils on cylinders 4,5 & 6 it makes no differance (still missfire) then if I do the same thing running on lpg it cuts out, am I right in thinking it is a fuel rail/injector fault on them cylinders? Thanks
siwill is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome