Need Help! '01 C320 Transmission Fluid - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-11-2012, 09:51 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2012
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Need Help! '01 C320 Transmission Fluid

I bought this car 97K and now it's 141K miles. I have never changed the transmission fluid because I forgot to do it. However, it runs great tho. This week, I bought 6qts Valvoline MaxLife which on the bottle it says compatible with Mercedes. I took them to my mechanic tell him to replace the old fluid. I have an automatic transmission. He put 5.5 qts. I drove out the shop for 5 minutes and at the red light, I was on "D" when release the brake, it just not move forward. I had to try push it for 5-10 seconds. It happened a few times. The power seems low and gear stay 1, sometimes move to 2 very smooth, sometimes not. I drove back to the mechanic immediately. He said the Valvoline MaxLife is not good for my car. He inspected the transmission (Took it apart) and told me to trade-in get a new car but it will cost alot to replace or replace the transmission!!! He said we should have used the Mercedes Specific Fluid. I am so sad now. I cannot decide what to do. My questions are:
1. Should I believe him? I mean it runs great even with the old fluid / even before the fluid change.
2. If it's true, I just cannot beleive that driving for 5 minutes can screw the transmission this bad? Is it too late to put the Mercedes Specific Fluid in....and try again? Will my car be back to normal?
3. Thank you for your help!
c320problem is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-12-2012, 05:31 AM
BenzWorld Senior Member
 
Andrzejek's Avatar
 
Date registered: Jul 2004
Vehicle: 00 C-230, 04 C-240
Location: Lancaster, CA
Posts: 468
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Take your car to a Benz dealer, or an indy mechanic that specializes in Mercedes, and have the tranny properly serviced. The tranny fluid level is critical, and it sounds as if your mechanic did not properly fill to the specified level.
Andrzejek is offline  
post #3 of 3 (permalink) Old 07-12-2012, 08:04 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
+1 to Andrzejek. People have used MaxLife and had no problems with it. But in your case I would first check the level, and then try the real deal 236.10 MB ATF.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome