1982 - 300SD: Wiring? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-07-2012, 08:09 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2012
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1982 - 300SD: Wiring?

CURRENT VEHICLE:
1982 - Mercedes 300SD
I just bought this car today... My first car was a 1981 - 240D. This would be the first time I've officially owned a Turbo Diesel.

It would seem obvious to some, but I've never seen anything like this:

PROBLEM #1
Windshield Wiper On/Off Switch
It started raining on the way home from this purchase. I turned on the windshield wipers and they DID come on.... HOWEVER, when it stopped raining, they didn't want to turn off. I double-checked the switch position on the blinker bar, and even toggled through the different speeds. The speed of the wipers increased and decreased normally, but they just wouldn't turn off.

Turned the car off upon arriving home, which killed the power to the wipers.. However, when the car is turned over again, the wipers come right back on.

PROBLEM #2
Instrument Cluster:
The rotary clock, oil pressure and temperature guages SEEM to work fine. HOWEVER, the speedometer, odometer, and tachometer are non-responsive. The speedometer and tachometer have a mind of their own. I was driving the speed of traffic on the highway at a steady pace when the speedometer suddenly (slowly) moved up to 60mph, then went back to 0mph.
The tachometer seems to randomly move on its own.

THIS ALL SOUNDS LIKE A SERIOUS WIRING ISSUE. I'll be removing the instrument cluster tomorrow to check for pinched, broken, and/or corroded wires - but I really don't know of anything else to check.

Sorry for the long-winded explanation; I'm just trying to get this fixed without rewiring the whole car.

Thank you benzworld!!!!!
JohntheNarwhal is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-08-2012, 04:18 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,608
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Welcome to Benzworld, the forum for your car questions is;

W126 S,SE,SEC,SEL,SD,SDL Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome