Not Starting after swapping out filters - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-28-2012, 02:26 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2008
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Not Starting after swapping out filters

Hello;

Got a 1983 MB 300SD turbo in great condition. Just yesterday while driving the car suddenly began to slow down and no matter how much gas I gave it wouldn't go any faster, until it came to a complete halt, purred a few seconds and then died.

I restarted the car and off it went without a problem. A few hundred yards further exact same problem happened. I restarted again with no problems.
I finally made it home.

today I replaced the pre and main gas (diesel) filters, opened up the bleeding screw and using the manual pump I pumped diesel until there were no more airbubbles. I closed the bleeding screw and went to start the car.

Now it turns over but it won't start. It tries to but doesn't go. sounds like there is no diesel entering the engine.

I tried to manually pump again but same result. Both filters are filled with fuel and tracing the lines they all are having diesel in them.

Any suggestions what that could be?

thanks

Lode
lodester is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome