Tachometer HELP!! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-25-2012, 06:39 AM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2012
Vehicle: 1989 Mercedes Benz 190E 2.6
Location: FL
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry Tachometer HELP!!

My Tach Stopped Working on my 1989 190E Ive Replaced the Fuses every single one of them and its still not working . Also all of my Dash Lights dont Work at Night what can i do to Fix this ?

Please Help
Thanks Tyler
mcclintocktyler is offline  
Sponsored Links
post #2 of 2 (permalink) Old 09-18-2012, 08:08 PM
BenzWorld Newbie
Date registered: Sep 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I am currently having exact same issue. my dash lights work (some, in AC controls) but cluster is out. please let me know if you have fixed this.
Nedim is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome