New Mercedes owner - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-05-2012, 03:20 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2012
Vehicle: 05 C230 Kompressor
Location: So Cal
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Garage
Send a message via Yahoo to jguzman
(Thread Starter)
Post New Mercedes owner

Hello all, I am a new Mercedes owner. I recently purchased an 05 C230 Kompressor with 71k miles on the odometer. I was very impressed by the speed and handeling.
The other night while driving/accelerating on the freeway I let my foot off the gas just as it was upshifing and I felt a thud/bump and lost power. The engine was reving normally but it felt like I was in nuetral. I was able to pull over to the side of the road and slowed to about 20mph... the transmission re-engaged and behaved normally the rest of the way home.

I have read some threads here about probems with this trany and the speed sensor and valve body. Could it be the same valve body problem?? Or would a transmision service solve my problem? It has not happened since last Sunday.
jguzman is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-06-2012, 12:39 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,172
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld, I put an answer on one of your other posts.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #3 of 3 (permalink) Old 06-06-2012, 06:38 PM
BenzWorld Extremist
 
jks2007red230's Avatar
 
Date registered: Feb 2012
Vehicle: 2007 Mercedes-Benz C230, 2007 Chevy Equinox, 2003 Saab 9-3 2.0t, 1996 Chevy Tahoe, 2000 Ranger R83
Location: Elizabethtown, Kentucky
Posts: 862
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome to Benzworld.
jks2007red230 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Long time BMW owner, First time Mercedes Owner! -=Hot|Ice=- General Mercedes-Benz 2 11-12-2011 11:16 AM
    new owner of mercedes macolio172001ag General Mercedes-Benz 2 02-08-2010 10:30 AM
    New Mercedes owner amazinblu General Mercedes-Benz 0 08-23-2008 11:36 PM
    Mercedes owner needs your vote for a non-Mercedes exexpat Off-Topic 1 12-28-2006 02:40 AM
    Please help a want-to-be mercedes owner....... petrolhead_23 W140 S-Class 11 07-31-2006 10:36 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome