S-Class W220 Battery Drain (TV?) - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-31-2012, 03:49 AM Thread Starter
BenzWorld Newbie
Date registered: May 2012
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
S-Class W220 Battery Drain (TV?)


I have a 2001 S Class (W220) and recently the battery keeps dying.
I think I have narrowed it down to the centre console/TV.
When I take the fuse out for this, then the battery stays full.

The TV is the smaller type (not wide screen).
I have tried taking out the Sat-Nav disc but still it drains the battery.

Are there any other tests I can perform myself at home?

Does anyone have any suggestions for me on how to overcome this?
If it means buying a new centre console - are these easy to fit, and how much would it cost?

Many thanks.
RN55ONE is offline  
Sponsored Links
post #2 of 4 (permalink) Old 05-31-2012, 09:23 AM
BenzWorld Elite
Diesel Benz's Avatar
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,320
Mentioned: 3 Post(s)
Quoted: 32 Post(s)
It might not be the Comand unit even if the current consumption goes away when you remove its fuse. It could be fixed from a software update or it could be another device at the same CAN bus that keeps the bus alive.
Diesel Benz is offline  
post #3 of 4 (permalink) Old 06-08-2012, 12:52 PM Thread Starter
BenzWorld Newbie
Date registered: May 2012
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
hi, my dad (whos car it is) took it to a garage that says the voice command part of the control centre is at fault.
they said that the voice command part was optional and it could be disconnected without having any ill effects with the control centre.
Is this true?
if so, how would I disconnect the voice command part of the unit?
(Or is there a fuse I can take out?)
RN55ONE is offline  
post #4 of 4 (permalink) Old 06-12-2012, 10:35 AM
BenzWorld Junior Member
Date registered: Jun 2012
Location: Livermore, CA
Posts: 28
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Pulling fuses is not the proper way to check for a current draw. Best way is to use an amp clamp. Checking for a current draw is not for the DIYer. Unless you have deep pockets and want to throw parts at it to try and find the draw. You need proper tools and time! But yes, I have replaced many comand units for a current draw. Sometimes a software update can be the fix too.
BenzTek Motorsports is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Flat battery / battery drain tip hox C215 CL-Class 0 06-14-2011 05:41 AM
    Battery drain problem 2000 S500L (W220) Askaroladi W220 S-Class 24 11-26-2008 08:43 AM
    Battery drain help Oracle12345 W201 190-Class 4 11-07-2008 05:36 PM
    Battery drain E55 AMG thorndale W211 E55 AMG, E63 AMG 1 06-08-2007 09:16 AM
    Battery drain Binny W201 190-Class 4 11-03-2006 05:09 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome