C280 2007 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-25-2012, 05:30 PM Thread Starter
BenzWorld Newbie
Date registered: May 2012
Vehicle: C280
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
C280 2007

I recently bought a 2007 C280. Within 3 weeks of driving it, it threw 7 codes relating to the cam adjustment and ESP/cruise control errors (codes 0064, 0060, 0703, C1161, C1707, C1025, C1700). The next day, while driving it to the service department it shut down and left me stranded! After being towed to the mechanic, they said they replaced all 4 of the sensors/magnets that were faulty related to the cam. They said that the other codes were just a result of the cam malfunctioning. I have read that the 2007 C280s have this common issue. The car has 50 K miles.
I am wondering if anyone has had a similar issue and if there was recurrent problems. I really hope that replacing these sensors will solve the issues.
Thanks in advance for your input.
ltbrahmas is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    AUX for 2007 C280 kenth0120 Audio & Telematics Forum 0 02-22-2011 09:01 PM
    Aux Input C280 2007 quzer W204 C-Class 2 12-18-2009 12:53 PM
    2007 C280 4 Matic TomKruc General Mercedes-Benz 2 08-08-2009 03:03 PM
    2007 c280 4matic AJCBenz W203 C-Class 7 08-05-2009 03:04 PM
    Just got my 2007 c280 4matic ladyb81 General Mercedes-Benz 2 12-05-2008 04:44 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome