Is 120 the right temp on a 420 SEL??? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-21-2012, 01:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2012
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Is 120 the right temp on a 420 SEL???

I have read here and there that temperature on my 88 420SEL can go up to 120, this is normal and there should not be a problem. My aux fan works and comes on, oil and coolant are where they should be, and still in not-so-hot heat of 70 outside, the gauge goes up to near 120 after 20-30 minutes of regular driving. Air really does not work well, and things just seem HOT.

The other day, the hose blew off the radiator soon after I parked, spewing coolant everywhere.

This all does not seem normal.

Anyone have any insite into this?? Is this a thermostat problem?? THANKS
mi420SEL is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-21-2012, 10:14 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,176
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld, it is not normal, thermostat? put your hand on the top hose and then the bottom hose and if they are the same temperature then the thermostat is working fine. Also try cleaning the fins in the radiator with a high pressure washer.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    2008 GL450 P0128- coolant temp below thermostat regular temp gbokas X164 GL-Class 5 05-06-2016 01:44 PM
    Coolant Temp sensor (kick in at lower temp) kianbeng R170 SLK-Class 1 04-29-2012 11:33 PM
    Temperature variance -- actual temp vs. gauge temp reading soundquest W124 E,CE,D,TD Class 7 06-19-2011 09:03 AM
    Dead Temp Guage after replacing temp sensor Stevewelsh W201 190-Class 5 11-29-2010 04:52 PM
    When outside temp is higher than 40', how come the temp gauge still shows 40'? noelb W163 M-Class 5 04-16-2002 02:43 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome