New Frustrated Owner - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-19-2012, 08:47 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Vehicle: 2007 C230 Sport
Location: Alabama
Posts: 46
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy New Frustrated Owner

Hello all,
I've viewed this website several times because I recently obtained my mercedes. It's the first car that I bought on my own and I want to take care of it. I like my car because it fits me. But, after only a year I am frustrated because it's giving me problems. I joined this site in hopes of learning more about my car and to currently get help or advice.

While driving down the highway all of my warning lights came on. I got to the traffic light waiting for it to turn green, the warning lights turned off. Just before the light turned green I noticed that the car lost power. When I finally got the car back on it was making a noise . Every time I turn the car on it makes the noise. When I turned the air on the noise got louder. I'm scared to drive it b/c I don't want to make it worse. But, the car has been sitting for a month. So, today I thought I would drive it around the block, since it hasn't been driven.

When I put the car in reverse it felt like the car didn't want to go. I pulled into the street still thinking I could drive around the block. While pushing the gas to get moving, the car still felt like it didn't want to move. So, even though my mph was rising the car was not going any faster. I decided to pull back into my yard and am now lost, frustrated, and scared b/c I have a feeling I'm about to be out of money I don't have, b/c I'm not working.

I've seen many readings on the internet about this make/model having problems. If possible can anyone advise me on what it may be or what I need to do? I am a female and don't want to get taken advantage of when I take it to the shop. Any help is greatly appreciated. I apologize for not knowing what forum to post this in.
VH1922 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-20-2012, 07:28 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,608
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Welcome to Benzworld, the first thing to do is repost this on the following link where owners of the same model may help you;

W204 C-Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #3 of 5 (permalink) Old 05-20-2012, 08:11 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Vehicle: 2007 C230 Sport
Location: Alabama
Posts: 46
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thank you

Thank you, Eric
VH1922 is offline  
 
post #4 of 5 (permalink) Old 05-21-2012, 07:32 AM
BenzWorld Extremist
 
RedMercedesGuy's Avatar
 
Date registered: Feb 2012
Vehicle: 2014 Mercedes-Benz C300, 2006 Lexus IS250 AWD, 2006 Land Rover LR3 SE, 2000 Ranger R83
Location: Elizabethtown, Kentucky
Posts: 874
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome to Benzworld. I think you need to look at the W203 C Class area. Make sure that you are not one of the affected engines.
RedMercedesGuy is offline  
post #5 of 5 (permalink) Old 05-21-2012, 03:50 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Vehicle: 2007 C230 Sport
Location: Alabama
Posts: 46
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thank you

Thank you, JKS. This is probably a silly question; but how would I know if I had an affected engine? I am new to this site and I see that there are numerous forums and posts.
VH1922 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
I'm frustrated! txfoster W140 S-Class 3 04-03-2012 03:24 PM
Getting Frustrated erich.schuette W202 C-Class 7 05-18-2010 04:32 PM
FRUSTRATED...Please Help tdelew W140 S-Class 11 01-05-2010 04:33 PM
Very Frustrated 300e owner kanoti W124 E,CE,D,TD Class 4 05-31-2007 08:51 PM
Frustrated with my ML MLTHREEFIFTY W163 M-Class 32 11-09-2005 12:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome