BAS ETS ABS warning lights on after electrical work. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-14-2012, 01:40 PM Thread Starter
BenzWorld Newbie
Date registered: May 2012
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
BAS ETS ABS warning lights on after electrical work.

Took my ML 270 CDI (W163) to auto electrician to fix problem on lights. He strips the fusebox (??????), many layers of fusebox! Took him 3 days to re assemble it, now as soon as I pull away, the BAS/ETS and ABS lights come on and stay on until I switch off. They do not come on at startup, only when I drive above about 20km/h. Cruise control still operates. Any ideas? Thanks.
BrianEllse is offline  
Sponsored Links
post #2 of 2 (permalink) Old 05-19-2012, 09:06 AM
BenzWorld Junior Member
Date registered: Feb 2012
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
did he have the battery removed while doing the work?? Try turning the key on and turning the steering wheel from lock to lock a couple of times. This recalibrates the steering angle sensor after a battery change. I don't know if this is your problem but its worth a try.
kered is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Instrument Cluster lights (the 4 2W bulbs) wont work ,warning lights/blinkers do WTF? PKariCL600 W140 S-Class 3 02-19-2012 04:19 AM
    4matic does not work. No warning lights on. Timon W124 E,CE,D,TD Class 3 12-19-2011 01:12 AM
    exterior lamp failure warning - all lights work! PurpleBarney W126 S,SE,SEC,SEL,SD,SDL Class 8 12-19-2009 01:10 AM
    W211 Brake Warning, ESP Warning Lights? willy_manilly W211 E-Class 0 02-16-2009 10:27 PM
    New Electrical Problem: Dash + Instrument Cluster lights do not work! sightless R170 SLK-Class 8 06-17-2008 01:09 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome