97 E320 Radio Possessed! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-15-2012, 11:16 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: 1998 E320 RWD 75k
Location: NW
Posts: 54
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
97 E320 Radio Possessed!

Hey all, need some advice on the radio. It had a mind of its own for about a week, coming on and off at will (even once when the key wasn't even in the ignition, that I know of). It seemed to start not working and as the car got warmed up it came on usually. I checked the fuses and they looked okay. But now it seems dead, won't turn on. After 15 years maybe that's all she's got? Any thoughts?
tmabiker is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-16-2012, 09:26 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Have you pulled it out of the dash? Some of these units have a fuse on the back of the radio but yours sounds more like a flaky connection. Pull it out and check all the wires and the connections. Radio removal keys are available from dealers and on eBay.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 4 (permalink) Old 04-16-2012, 10:48 AM Thread Starter
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: 1998 E320 RWD 75k
Location: NW
Posts: 54
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
Thanks, and no, I haven't pulled it out, my auto knowledge goes about as far as checking the fuses. But it sounds like its time to learn a bit more.
tmabiker is offline  
 
post #4 of 4 (permalink) Old 04-19-2012, 11:55 AM Thread Starter
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: 1998 E320 RWD 75k
Location: NW
Posts: 54
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
So I happened to notice that when I turn the car off, the little light on the radio that signals alarm starts coming on an off, even though the radio won't give even the slightest sign of life when the car is on.
tmabiker is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
POSSESSED RADIO !! 2004 E320 benzboy850356 W211 E-Class 10 05-25-2011 09:11 PM
SL320 Possessed by radio demons scott9931 R129 SL-Class 2 05-22-2007 07:41 AM
car is possessed e320nbama W210 E-Class 1 09-28-2006 06:46 AM
radio code 95 original e320 radio Guest (MBNZ) Audio & Telematics Forum 1 06-04-2002 06:11 AM
1995 E320 Radio - How to Set Radio Stations??? Guest (MBNZ) Audio & Telematics Forum 3 01-15-2002 10:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome