1997 MERCEDES C230 TRANSMISSION ISSUE? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-09-2012, 10:01 PM Thread Starter
BenzWorld Newbie
Date registered: Apr 2012
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

Hi, I am new to this forum. I recently purchased a 1997 C230 with 210k miles. Love it!! I needed a car to take to my office which is only 5 miles away. I took it on the highway today for the first time and I noticed that at 60mph it shows 2400 rpm. I think is too high (I also have a 2012 Camry which shows 2000rpm at 70mph). Is this normal or there is something wrong with the transmission? I also tried to count the gears shifting and only felt 4 instead of 5. Did anybody have the same problem? (The car has a week engine mount which I will replace this week, I don't know if it affects the transmission in any way)
Thank you,
mervas is offline  
Sponsored Links
post #2 of 4 (permalink) Old 04-13-2012, 04:52 AM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,072
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #3 of 4 (permalink) Old 04-15-2012, 05:52 PM
BenzWorld Junior Member
Date registered: Apr 2012
Posts: 22
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
You felt 4 shifts?

Sent from my Autoguide iPhone app
AmStrat10 is offline  
post #4 of 4 (permalink) Old 04-16-2012, 03:46 AM
BenzWorld Extremist
jks2007red230's Avatar
Date registered: Feb 2012
Vehicle: 2007 Mercedes-Benz C230, 2007 Chevy Equinox, 2003 Saab 9-3 2.0t, 1996 Chevy Tahoe, 2000 Ranger R83
Location: Elizabethtown, Kentucky
Posts: 862
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
It might be a liittle bit high in the RPM range. I think mine is a bit lower, but not much. If your Camry has a 6 cyl. engine it is probably a 3.0 liter, which is larger than the 2.5 liter in the C230. Therefore the RPM's will normally be higher in the MB.
jks2007red230 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Instrument Cluster issue W202 1997 C230 kdoubleu W202 C-Class 10 10-25-2013 07:36 PM
    1997 C230 Transmission Fluid veli410 W202 C-Class 4 08-26-2011 10:42 PM
    FS- 1997 Mercedes c230 benz2042 For Sale/Wanted/Trade/Giveaway 6 01-29-2011 07:08 AM
    1997 C230 Rough Transmission veli410 W202 C-Class 3 01-21-2010 05:17 PM
    1998 C230 Transmission & Computer Issue PBaker General Mercedes-Benz 0 04-22-2006 09:01 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome