ac problems - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-12-2012, 12:53 PM Thread Starter
BenzWorld Junior Member
Date registered: May 2008
Vehicle: 1999 E300TD
Location: Wilmington, NC
Posts: 29
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
ac problems

My ac compressor has stopped coming on. The compressor is not locked up because it turns freely by hand. Unlike some other peoples problem, my ac is not stuck in ec mode. My code 7 (refrigerant pressure) is 0. I am also showing 7 different fault codes. They are B1226 in car temp sensor w/blower, B1228 &B1229 heater output temp sensor, B1230 AC evap temp sensor, B1232 AC refrig pressure sensor, B1233 AC refrig temp sensor, B1234 AC sunlight sensor. Where would I even begin to figure out what the problem is, and how I should attempt to fix it. Thanks
graysilm is offline  
Sponsored Links
post #2 of 3 (permalink) Old 03-12-2012, 11:37 PM
BenzWorld Elite
Diesel Benz's Avatar
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,320
Mentioned: 3 Post(s)
Quoted: 32 Post(s)
I guess your car is a Mercedes-Benz but since you are posting at the general section and you don't have any models mentioned in your profile, you could give more details.

You do seem to have a lot of sensor faults, sounds unlikely that all are real (all sensors broken). But why not start from the first one and figure out the issue. If you can fix it from a loose connector, you might get others fixed too, would not harm. Otherwise continue to the next fault code.
Diesel Benz is offline  
post #3 of 3 (permalink) Old 03-13-2012, 08:50 AM Thread Starter
BenzWorld Junior Member
Date registered: May 2008
Vehicle: 1999 E300TD
Location: Wilmington, NC
Posts: 29
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Sorry Diesel Benz. My car is a w210 1999 E300TD. I will repost this in the W210 forum.
graysilm is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    fuel pump problems and running problems 90-420sel W126 S,SE,SEC,SEL,SD,SDL Class 1 11-13-2011 03:12 PM
    e320 key problems and sunroof and light problems scrappyloz W210 E-Class 11 08-02-2011 12:40 PM
    iPhone integration problems and AUX problems... nycdude777 C219 CLS-Class 3 01-27-2009 07:21 AM
    Stored 1993 S420 has fuel problems-Gives sudden starting problems-solution needed heartmd W140 S-Class 15 12-09-2007 01:45 PM
    G500 Problems - Squeaks, window problems, etc Miltona G-Class 2 10-19-2004 01:16 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome