b180 petrol starting problem - Page 2 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 03-13-2012, 08:23 PM
BenzWorld Junior Member
Date registered: Mar 2012
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have tried fuel injector treatments, Fuel boosters and no change.
Florence41 is offline  
Sponsored Links
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1998 Vtio 113 petrol problem Araich V-Class 2 11-09-2010 11:49 PM
    1989 E200 petrol.Hard starting. SHANE2002 W124 E,CE,D,TD Class 3 09-07-2010 04:04 PM
    B180 petrol version Wazafi General Mercedes-Benz 0 03-31-2010 07:35 PM
    mercedes 409 van (1982) petrol - starting problem - mercedes transporter belfast_phil V-Class 1 08-17-2009 03:40 PM
    Starting Problem (Back window rolls down when starting up the car) fastneutron W202 C36 AMG, C43 AMG 3 08-08-2004 10:23 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome