2005 C200 Diesel starting fault - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-05-2012, 11:09 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2012
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post 2005 C200 Diesel starting fault

Hi Newbie here !!

We have a c200 diesel which has done 80k with full service history, but now occasionally when it's warm it won't start and needs to be left for 10mins, the car will then start normally.

No problems at cold, I have changed the batteries in the key fob, there are no fault codes showing at all when the fault occurs, some suggested it was an immobilser fault, locking the car with the key remote and unlocking makes no difference.

I have seen a post where someone had a similar fault and changed the crank angle sensor with no luck

Help Any ideas ??? Mark
Sunseeker1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-05-2012, 02:25 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
A crankshaft position sensor might explain why yours does not start when warm. I know this is true with gasoline cars. If diesels have those too it is worth a try. They are not expensive and people say it is pretty easy to change yourself.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    c200 starting problem kojo W202 C-Class 1 06-06-2011 06:55 PM
    starting problems when engine is cold c200 fjallaking W202 C-Class 32 01-14-2011 09:11 AM
    Help please! C200 not starting up. MarkLim81 General Mercedes-Benz 0 01-04-2011 02:56 AM
    C200 ignition fault sherpa350 General Mercedes-Benz 0 08-15-2009 02:24 AM
    Fault code 6 and Car starting problems jcochrane007 W124 E,CE,D,TD Class 3 03-11-2005 05:55 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome