Happy to have found ya, & out from the shadows! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 02-16-2012, 11:03 PM Thread Starter
BenzWorld Junior Member
 
kSea's Avatar
 
Date registered: Feb 2012
Vehicle: 1990 420sel
Location: San Francisco
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Happy to have found ya, & out from the shadows!

Hi Ho!
Thought I would take a second to say hi after lurking for a few weeks as a new member & drinking in all of the kickass knowledge & suggestions on these pages.

I fell in love with Mercedes a few years ago, when I found a '70 280sel for $400. It was on it's last legs, smoked like hell, but it was then & there that I was officially hooked. After it died I got a '71 280se which was towed due to parking tix (the bane of living in San Francisco) - had I known the cars I had then I would have been much more careful. They were beat up, but absolutely gorgeous in their own way.

Now, here we are. I just bought a '90 420sel which has a few small problems (sunroof, hesitation, rough idle, a few other small things) but in general, she's a beauty, I'm back in love, and incredibly happy I found this site! I've already gotten tons of useful information.

Anyway, just wanted to introduce myself and say hi, and thanks!

~ kSea flux
kSea is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 02-18-2012, 06:25 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,187
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #3 of 10 (permalink) Old 02-18-2012, 07:36 AM
BenzWorld Elite
 
Date registered: Jun 2011
Location: Illinois
Posts: 3,775
Mentioned: 0 Post(s)
Quoted: 81 Post(s)
Welcome. We'd love to see some pictures when you get a chance.

Do some forum searches in the 126 section. The rough idle particularly is a very common problem with the 116 and 117 engines, and there are several potential fixes, from plugs, and or wires, to the idle control valve or module, fuel distributor, vacuum leak, etc etc. Vacuum leak is probably the most common cause. For the sunroof, I'd recommend getting some white lithium paste, or the actual MB sunroof lube(gleitpaste) and again, do a search for how to lubricate it.(google may be better, the site search is notoriously fallible.) The lube can be gotten at the dealer, mercedessource.com, or peachparts,com. If that doesn't work, you may want to have it looked at by a pro if you're not pretty car savvy, it can get a little complicated from there. But again, searching will definitely help if you plan on doing any projects yourself.

My last piece of advice would be to just browse through past threads in the 126 section. You will definitely learn a lot of valuable information that will come in handy.
w126Sam is offline  
post #4 of 10 (permalink) Old 02-18-2012, 12:51 PM Thread Starter
BenzWorld Junior Member
 
kSea's Avatar
 
Date registered: Feb 2012
Vehicle: 1990 420sel
Location: San Francisco
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hey 126Sam, and thank you! Herea are a few shots of Marlena (as in Dietrich, a tough but beautiful old german broad).

I've been browsing like mad, and as far as the sunroof goes, even though I have a mechanical background (eight years as a Harley Tech) I'll most likely take it to a pro - there are some things that I've learned that are much better handled by people who know their stuff, and the fuel injection - as well as the sunroof, are completely mew beasts to me - though I look forward to learning!
And - pardon me for perhaps a ridiculous question, but what is the 126 section?

As far as vacuum lines, I know what they usually look like, (rubber hoses) but are the 420's for some reason steel lines?
The hesitation is only intermittent - usually on cold mornings or if I haven't driven her for a day, then goes away after a very brief time... but that's for the appropriate thread, isn't it?
I'll have plenty more questions coming up I'm certain, as she is a beauty & I want her to last - and get better!

Thank you for the welcome, and I'm sure I'll see you around the site!

~ kSea
Attached Thumbnails
Click image for larger version

Name:	P1000109.jpg
Views:	58
Size:	34.9 KB
ID:	427145   Click image for larger version

Name:	P1000115.jpg
Views:	55
Size:	52.6 KB
ID:	427146   Click image for larger version

Name:	P1000116.jpg
Views:	56
Size:	42.2 KB
ID:	427147   Click image for larger version

Name:	IMAG0083.jpg
Views:	78
Size:	52.9 KB
ID:	427148  
kSea is offline  
post #5 of 10 (permalink) Old 02-18-2012, 04:30 PM
BenzWorld Elite
 
Date registered: Jun 2011
Location: Illinois
Posts: 3,775
Mentioned: 0 Post(s)
Quoted: 81 Post(s)
Nice. Is she black or midnight blue? I'm not sure about the vacuum hoses... all of them on my engine are rubber that I know of.
w126Sam is offline  
post #6 of 10 (permalink) Old 02-18-2012, 05:02 PM Thread Starter
BenzWorld Junior Member
 
kSea's Avatar
 
Date registered: Feb 2012
Vehicle: 1990 420sel
Location: San Francisco
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by w126Sam View Post
Nice. Is she black or midnight blue? I'm not sure about the vacuum hoses... all of them on my engine are rubber that I know of.
She's black. Picked her up for only $1450, too, which I feel is a pretty damn good price - the interior shows only a little wear, the paint is pretty good (though not perfect - but a good waxing will make quite a difference, I'm sure) and besides what I mentioned plus a few other minor things (every climate control button leads to the defrost) she's in quite good shape - just needs some love, which I'll be happy to give her!
kSea is offline  
post #7 of 10 (permalink) Old 02-18-2012, 05:18 PM
BenzWorld Elite
 
Date registered: Jun 2011
Location: Illinois
Posts: 3,775
Mentioned: 0 Post(s)
Quoted: 81 Post(s)
Nice price. Yea I bought mine for $2500, and it's probably a 6 or 7/10, but I did zero research on the car, and it was really only my second time buying a car buy myself. About the climate control, that could be vacuum pods(which I hear are an easy fix) or the button controls themselves. The vacuum pods should be pretty cheap, and I'd go used for the button console if that doesn't work, they're outrageously priced new. If you're not a junker, someone on here should definitely be able to help you.
w126Sam is offline  
post #8 of 10 (permalink) Old 02-18-2012, 05:22 PM Thread Starter
BenzWorld Junior Member
 
kSea's Avatar
 
Date registered: Feb 2012
Vehicle: 1990 420sel
Location: San Francisco
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by w126Sam View Post
...If you're not a junker, someone on here should definitely be able to help you.
And that's just another reason why I'm so happy I found this site!
kSea is offline  
post #9 of 10 (permalink) Old 02-18-2012, 06:01 PM Thread Starter
BenzWorld Junior Member
 
kSea's Avatar
 
Date registered: Feb 2012
Vehicle: 1990 420sel
Location: San Francisco
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by db51 View Post
I have an 89 300SE that I hadn't driven in 5 years...I now have it up and running but am having issues with the heat. Sometimes it blows cold air (not AC running) and then it will simply kick in on it's own for no good reason and work until I push the button to turn it off. When you attempt to turn the heat back on, same scenario. Also, I cannot get the buttons to switch it from the defrost setting down to the vents and floor...running on defrost all the time.

Tach quit working out of the blue as well after sitting for so long and I have no power to the radio which worked when I parked it. BTW....how in the hell do you get the radio out of it...or remove the console...I see no screws or clips. lmao....duh. Fuses seem to be ok under the hood.

??
Perhaps you should do a search for an appropriate thread (such as climate control &/or tach threads if you can't find an answer) & post this somewhere besides the new member introductions?
kSea is offline  
post #10 of 10 (permalink) Old 02-18-2012, 07:52 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,187
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Here is a link to the 126 section in case you have not found it yet;

W126 S,SE,SEC,SEL,SD,SDL Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    The Nouveau Poor Recession Shadows America's Middle Class Teutone Off-Topic 4 11-11-2010 02:45 PM
    happy i found this site (MB tech mention it) c230kno General Mercedes-Benz 0 09-08-2008 09:49 PM
    Shadows with lights slkpsm R170 SLK-Class 3 09-16-2007 01:27 PM
    R171 Commercial. Driving to avoid the clouds/shadows. cvayala R171 SLK-Class 6 03-21-2006 10:21 PM
    HELP!!! how do I remove emblem shadows/prints/stains tresean1 W203 C-Class 10 06-05-2005 08:34 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome