S500 2001 Battery Drain Issue - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-11-2012, 06:07 PM Thread Starter
BenzWorld Junior Member
modulacom's Avatar
Date registered: Dec 2004
Posts: 19
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
S500 2001 Battery Drain Issue

I have own the car for not quite 4 years has had one MB Service as I have only covered 8000 miles in that time.
I purchased the car with no mention of the keyless-entrée & go? So for about 6 months I used the key fob no issues car great very reliable.

But started using the key cards with new batteries and new MB main car battery. After a hot summer it started to behave badly as though the start button was continuing to fire up the car on its own. I demo’d the issue with the engineer and his comment was that he didn’t know, said it needs to have it diagnose, so in it went.

The report came back that the Tyre sensor is failing and needs to be replaced. I replied stating that the chap that sold me the car said that it is a known issue with some S500 of that year and to ignore it as no one to date has been able to resolve it. But he was sure it was the main reason that I was getting problems (start by resolving this and then we can look further. So I agreed he asked for the car to be kept over night as they needed to look into some problems. He never resolved the tyre pressure issue!! but charged me and I paid

When it came to collect the car I paid for a replacement sensor & labour. I got half a mile down the road and the suspension went out of control for a little way then it settled down but has not felt as smooth as it was before. Also the car over heated and I was told by the MB Engineer that it needed a new sensor to control it from overheating so back in it went it new sensor fixed the problem.

But I was still at the first hurdle with the Keyless system not working and draining the battery overnight.
A couple of years have passed I asked for help but nobody came up with the right answer I removed the fuse the powers the Keyless system and it stopped the drain on the battery until a couple of weeks ago it has started again. So I am back to disconnecting the power from the car / computer and reconnecting when I need to use the car. ( I know this is not a good a good idea ) so any help would be great…

S500 2001 model first reg oct 2002 first owner paid £87,250.00 FMBSH for 6 years then I purchased the car 60,000 on the clock now 68000

Battery drain on and off started with Keyless go issues so removed fuse; drain on battery stopped. But with the cold weather it has started again?? It is a beautiful genuine fully loaded sedan. No rust SS exhaust system like new under side fly’s through MOT every year.

Help I need somebody not just any body.... some one that knows my issue.. Thanks
modulacom is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Workaround for Battery drain issue on 2001 c240 gangsta101 W203 C-Class 7 01-10-2016 11:03 AM
    Battery Drain Issue Poet W124 E,CE,D,TD Class 3 12-24-2009 12:57 PM
    Battery drain issue mattwestm W124 E,CE,D,TD Class 13 12-20-2009 11:01 AM
    S500 2001/2 65000 mile battery Issue itresolve General Mercedes-Benz 0 07-23-2009 05:26 PM
    Battery Drain issue - help rbartholomew W124 E,CE,D,TD Class 1 07-09-2008 05:36 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome