2003 ml500 No heat freezing outside help! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-10-2012, 01:56 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2011
Vehicle: 2003 ml500
Location: Montreal, QC, Canada
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation 2003 ml500 No heat freezing outside help!

Hello, I have a 2003 ml500, i have no heat. I went to a benz specialist he told me i needed to change the heat auxiliary pump and so i did...Still no heat. i have looked around in other posts on this site and i saw people talking about blend air motor or a flap actuator. The part number for models 2002 and older is 163 820 0108. the part number i found for 2003 models is 203 820 1642 but its called a flap actuator or a STEPPER motor. So i am very confuised and frustrated to what all these motors and actuators are. Can someone just tell me what i need for a 2003ml500 with no heat.Is 203 820 1642 the right part number i need??? plzzzz help
Also my center vent doesnt blow any air and i cant control where i want the air to be blown anymore.
I love this SUV but im 24 years old and its giving me gray hairs !!
The_bawss is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-11-2012, 04:20 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,602
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Welcome to Benzworld, have you posted in the forum for your vehicle?

W163 M-Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Blizzard in OK, no heat in ML500 mlboyer65 W163 M-Class 4 03-21-2011 02:45 PM
2002 ML500 Will Not Generate Cabin Heat bigdaddybenz W163 M-Class 34 11-29-2010 01:07 PM
No Heat & I am Freezing! gasparetto W126 S,SE,SEC,SEL,SD,SDL Class 15 02-25-2006 01:54 PM
***WIN a 2003 ML500*** They are giving away a ML500 at .............. garyroseyu W163 M-Class 3 12-02-2002 01:50 PM
Buurrr!!! It's freezing inside my car....no heat!! Benzola SD W126 S,SE,SEC,SEL,SD,SDL Class 7 11-04-2002 07:49 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome