problems w/ high beams and other questions - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-08-2012, 06:56 AM Thread Starter
BenzWorld Junior Member
Date registered: Feb 2012
Vehicle: 2004 S500 4Matic
Location: PA
Posts: 46
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
problems w/ high beams and other questions

The high beams worked on my '93 400SEL a few days ago, but when I put the blinker multi control to the high beam position, the lights go out. I was able to pull and hold for highs, but that ended as well - is it the micro switch in the column, anyone have similar issues?
I'm just curious about the headlight washers - is there a knob somewhere that I can't find or does it do it automatically when I do the windshield?
I've got that driver side condensation between the two panes issue as well - I think I'll take the door apart and take the glass and open it up, reseal it, suck it together with a shop vac and inject nitrogen. I'll keep you all informed (I was a diesel mechanic in the air force whilst in Deutschland many moons ago!)
Someone once told me that the mechanic guys working on cars are not rocket scientists - I took that advice and ran with it - I like to work on the mechanical things myself and save some dinero.
froschjagd is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    High Beams Flasher doesn't work but high beams do... doctorkaligari R170 SLK-Class 8 04-08-2013 06:34 AM
    2000 clk430 wiring harness to use both fog and high beams with low beams? 034klc C208/A208 CLK-Class 0 12-16-2010 12:11 PM
    New bulbs for my AMG fog lamps, Xenon low beams, and Halogen high beams. lynns R129 SL-Class 17 01-16-2010 03:54 PM
    Electrical Problems, Startup, Stereo, High Beams... realog W202 C-Class 10 10-09-2008 12:07 PM
    Birger, I got it to work! Bi-Xenon high beams & halogens high beams!!... Drew W163 M-Class 15 06-11-2002 08:00 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome