1997 S500 Climate Control...need professional advice. - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-01-2012, 02:41 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2011
Posts: 21
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1997 S500 Climate Control...need professional advice.

So, I posted this in the W140 forum and got great answers, here's where I'm at now...I had a problem where when you accelerate the lcd on the fan control would drop to the first bar, then the fan would quit for 30 seconds, the LCD would return and the fan would then return....it gradually got worse, started doing it more frequently, then when I hit bumps, then when I hit the brakes, and finally when I closed the passenger door (Coupe)....It quit doing it when it got cool outside, even with the fan on max and setting at low, it worked perfect, well, winter has been very mild here...we are now back in the 80's....so it started again, all the time, so I broke down and started the repair process, with advise from this forum...

Today we replaced the voltage regulator on the blower...here's what happened, and where I need your help....Now instead of doing it 100 times a day, it only did it twice.....which is great, this is in about 3 hours of driving...whereas before, it was every single time I accelerated....what bugs me, is this is how it started before. Should I be looking at a defective connector between the blower and regulator, and we temporarily fixed it by reconnecting the plug to a new regulator? Or could this be a blower motor problem that wears away at the voltage regulator?
Two keys, it only does it when it's warm out, and the LCD reacts prior to the blower....when it was at it's peak...the LCD would flicker many times before the blower would return...again... it is 99.9% better...but I'm concerned it will worsen yet again.....and Florida Heat will really suck without a/c.

Thanks in advance.
rbutters500 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1997 S500 CLIMATE CONTROL RESULTS XROBK818X W140 S-Class 0 12-11-2010 09:45 PM
    1997 S420 climate control domespacio W140 S-Class 0 12-16-2009 09:44 AM
    help - 1997 e320 climate control ?? donaldgarzino W210 E-Class 5 04-29-2009 07:20 PM
    Climate control unit C230 1997 Palm Beach Henry W202 C-Class 13 01-10-2009 10:08 PM
    Problems With 1997 C280 A/C and Climate Control bonawitz07 W202 C-Class 4 07-20-2008 06:07 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome