1997 S420 immobilizer - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-31-2012, 06:31 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1997 S420 immobilizer

Can anyone tell me that if the key immobilizer is faulty,can that cause the engine to not crank! The igniton switch has been replaced. The shift selector switch is also replaced. The starter will function if terminals are jumped. Dealer says that the immobilizer will allow the engine to crank,but will not allow the engine to start. The remote will not operate the door locks. Thanks!!
jrysch is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-31-2012, 06:57 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Update. Car will start by turning ignition on and jumping the starter terminals.
jrysch is offline  
post #3 of 6 (permalink) Old 01-31-2012, 08:13 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
If you have a spare key try that. Otherwise replace the key battery.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #4 of 6 (permalink) Old 01-31-2012, 11:55 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Replaced both key batteries now the alarm system functions but it still wont start.
jrysch is offline  
post #5 of 6 (permalink) Old 01-31-2012, 01:13 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
On my car the key batteries are not needed to start the car, only for the remote functions to work. Since you have replaced the ignition switch maybe it has something to do with the EIS (electronic ignition system). Some people have cleaned the window in the key and some part around the ignition switch that communicates with that end of the key. Another possibility is your key has gone bad and that's why I suggested you try your spare.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #6 of 6 (permalink) Old 02-01-2012, 01:58 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Musikmann View Post
On my car the key batteries are not needed to start the car, only for the remote functions to work. Since you have replaced the ignition switch maybe it has something to do with the EIS (electronic ignition system). Some people have cleaned the window in the key and some part around the ignition switch that communicates with that end of the key. Another possibility is your key has gone bad and that's why I suggested you try your spare.
Found open circuit from passenger floor panel plug to starter trigger. Violet/white wire had start signal to plug. Not continuous as white wire near passenger exhaust to starter post. Benz wanted $345.00 for the harness. Was able to rewire. Thanks for the help!!!
jrysch is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    W202 200c 1997 Hazard/Indicator /Immobilizer fault er kevincombrink General Mercedes-Benz 0 01-27-2012 11:28 AM
    Help Needed; 1997 S600 Coupe security/immobilizer w140guy W140 S-Class 3 03-15-2011 05:05 AM
    Hey Hey s420 1997 mrmyles General Mercedes-Benz 2 09-22-2009 11:07 PM
    1997 S420 amirtal33 General Mercedes-Benz 13 03-03-2009 04:08 PM
    bought 1999 S reg s/a a class cant find immobilizer port 2 put my immobilizer key in Ali_c W168 A-Class 2 08-28-2005 01:01 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome