1984 300TD - stopped running - suggestions? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-26-2012, 06:03 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2012
Vehicle: 300TD Wagon 1984
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1984 300TD - stopped running - suggestions?

I have a 1984 300TD wagon that I have had for a month and ran fine when I purchased it. I took it for a drive the other night. Doing 55 MPH, it made a whirring noise, lost power, coasted to a stop and wont start. The engine will crank but not fire - not seized. The lights and the gauges seem to function, electrical seems OK. Any suggestions on what and where to trouble shoot? Fuel pump, turbo, timing belt, etc? Appreciate any help. Thanks.
Porchlight is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-27-2012, 07:18 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,160
Mentioned: 3 Post(s)
Quoted: 289 Post(s)
Best place to ask this question is on this link;

W123 E,CE,D,CD,TD,TE Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    '87 300TD odometer stopped working panamracer W124 E,CE,D,TD Class 10 02-08-2011 04:13 PM
    85 300TD Tach stopped working- where to check? njview W123 E,CE,D,CD,TD,TE Class 8 09-15-2009 09:15 AM
    1997 420, Auto AC fan stopped running; advice? harbrman W210 E-Class 2 11-19-2008 02:16 PM
    '84 300TD turn signals stopped working morav W123 E,CE,D,CD,TD,TE Class 2 04-10-2008 03:03 PM
    300TE stopped running RCJones W124 E,CE,D,TD Class 6 12-27-2006 04:09 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome