Need some help with my benz ML320 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-22-2012, 04:17 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2012
Vehicle: 1998 Mercedes Benz Truck ML320
Location: Arizona
Posts: 40
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Post Need some help with my benz ML320

I bought a 1998 Mercedes Benz ML320 I have a code that came up the other day it was P0700 Transmission Control System Malfunction.
I have read alot of forums that state that changing the conductor plate will fix it.
Heres what my truck is doing,The fluid was low I filled it to MB specs.
It drives fine for awhile until it gets up to temperature, then if I turn the truck off, then when i restart it it goes into limp mode. As long as I dont turn it off she drives and shifts great.

What could it be, i will have to do the work myself as I cannot afford to take it to the dealer.

Any help is much appreciated. Thank you in advance
BIGAZDAWG is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-23-2012, 01:44 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
You'll be much better off asking this on the W163 forum as there are several great diagnosticians and lots of owners there. But your garden variety scanner only gives you very generic MB transmission codes so you need to get a better scan before throwing parts at the truck.

And you need to discover why the ATF was low. There is an electrical connector that is prone to leak and fluid can wick up the wires into the transmission control module. That might also explain your symptoms.

Mercedes Benz - Das beste oder nichts!

Last edited by Musikmann; 01-23-2012 at 01:47 PM.
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
New and first Benz W163 98 ML320 slim79 General Mercedes-Benz 0 05-08-2010 04:44 PM
ML320 BlueTEC on Mercedes-Benz TV Wolfgang W164 M-Class 1 09-28-2008 12:17 PM
Security Code for Mercedes-Benz ML320 mithra General Mercedes-Benz 2 06-03-2004 01:44 PM
Security Code for Mercedes-Benz ML320 mithra W163 M-Class 3 06-03-2004 12:00 PM
Mercedes-Benz ML320 Haris W163 M-Class 1 01-17-2003 10:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome