1998 C280 Coolant Disapearing & Oil HI Message - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-17-2012, 12:56 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2012
Vehicle: 1998 C280
Location: Oahu, Hawaii
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Smile 1998 C280 Coolant Disapearing & Oil HI Message

Hi All,
New to this site and the world of Mercedes-Benz. I thought I was pretty lucky to find a pristine 1998 C280 with only 23k miles. Carfax checked out and all maintenance was done by the dealer every year. After a few hundred miles, the coolant light went on. I topped off the coolant although it just seems to be disapearing, no leaks and all hoses look like they are in order. Now the "Hi Oil" message in the odometer shows up when driving around. Checked the dipstick and oil is in proper order with no "milky" color. The car is going to the repair shop, although was wondering if anyone else experienced this and what the cause/problem may be. Any feedback is greatly appreciated! Love the car and just hope this isn't too much of a problem. Thank you!
Calypso808 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-17-2012, 08:44 AM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,465
Mentioned: 10 Post(s)
Quoted: 356 Post(s)
Calypso - welcome to the forum, and congrats on finding this car. In a barn?

Would you please add your profile to your posts by going to User CP ^^ as model, year, and location can often help replies here. Also it is better to post your queries in your your own model forum (W202) as listed on the Index page. That's where owners of similar cars will hang out.

About your problems - I'm not convinced that they are connected, after the basic checks you have done. The high oil warning might just be a faullty sensor, if your dipstick disagrees with the alarm.

Regarding the loss of your coolant, it could be weeping from your water pump while the engine is running, and the minute drops get thrown everywhere. So you may find no evidence of this leak. A 'pressure test' on the radiator or coolant header cap will show if this is your problem.

Of course on a 14 y/o car other coolant hoses might have small cracks that leak slightly when under working pressure. It might be an idea to change them all.
keyhole is offline  
post #3 of 3 (permalink) Old 02-10-2012, 12:47 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2012
Vehicle: 1998 C280
Location: Oahu, Hawaii
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks! A Much Bigger Problem Than Expected...

Hi Keyhole,

Thanks for your reply! Sorry been so busy with work and the C280 has been in the shop during this time. The mechanic (a highly regarded and recommended MB mechanic) notified me that my Head Gasket was leaking and coolant was leaking into in the engine oil. I guess when I checked it wasn't mixed like the "milky" fluid. Also, explains my "hi Oil" light...Looks like I"ll be looking at around $3700 in repairs. (Ouch!). But at least the mechanic said everything else is in great shape and he said that after fixing this problem I'll have a superb vehicle. Never imagined repairs for this vehicle could cost so much, but then again, its far superior to the Lexus and Infiniti's I've been driving.

Yes, the car was almost in a barn, it was in a garage of the owner who hardly ever drove it, except to the grocery store. I couldn't resist buying it when I found it. Immaculate in every way, even the mechanic couldn't believe the condition for the year.

Thanks again, I'm looking forward to getting my car back soon and can't wait to start enjoying it.
Calypso808 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Top Up Coolant Message mitaka W251 R-Class 33 10-12-2015 04:09 PM
    Top Up Coolant Message mitaka W164 M-Class 6 04-28-2010 08:22 PM
    E-350 - Engine Coolant message naheedsk W211 E-Class 2 02-11-2010 10:28 AM
    Engine Coolant Message but Coolant is ok? xxnonamexx W204 C-Class 2 11-16-2008 09:01 PM
    Disapearing Doors mbnz230 W210 E-Class 2 08-03-2007 08:11 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome