1996 R129 SL500 ASR and EPC lights on - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-28-2011, 05:40 PM
BenzWorld Newbie
 
Date registered: Nov 2010
Vehicle: 1996 SL 500
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Talking 1996 R129 SL500 ASR and EPC lights on

Hi, I have a 1996 SL500. For no reason the ASR and EPC lights have come on. Now the car runs extremely rough and in limp mode. I can also restart car and after 6 to 8 attempts, car will run fine with no lights on. I would be extremely grateful if someone could help me out.

Thank you.

Steve
StephenB916 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-29-2011, 10:32 PM
BenzWorld Elite
 
Date registered: Jul 2004
Posts: 3,817
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
You really need to take it to a shop and get the codes read. If you have an OBDII reader by all means hook it up and see what you get, but it's not going to tell you why those warning lights are on. 1996 is the first year that those modules can't be read with a flash code reader.
deanyel is offline  
#3 (permalink) Old 09-12-2012, 03:37 PM
BenzWorld Junior Member
 
Date registered: May 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
what did you do? have same problem

Steve how did you remedy? John
giovanni50 is offline  
#4 (permalink) Old 12-30-2013, 06:53 PM
BenzWorld Newbie
 
Date registered: Dec 2013
Vehicle: 1996 sl500
Location: brooklyn, ny
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Stephen please help

I have the same exact problem with my 1996 sl500. Today, I spent 40 minutes trying to start the car without the 2 lights turning on. One shop told me it's a problem with the throttle body.

How did you fix your car? what was the problem?
renata123 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1996 R129 Rearview mirror ejeffrjr R129 SL Class 0 09-27-2011 10:07 AM
Bose amp pinout of 1996 R129 ben543 R129 SL Class 1 10-19-2010 04:02 AM
1996 R129 shop manual. FtWorth1996SL500 R129 SL Class 1 02-17-2010 04:25 PM
R129 SL500 1994 vs SL500 1997 MercuriousBends R129 SL Class 11 08-03-2009 05:08 AM
1996 SL500/R129 Volume knob out of control aecesq Audio & Telematics Forum 1 10-28-2007 07:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome