2007 E550 OBD II Fuse? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 12-13-2011, 05:23 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2011
Vehicle: 2007 E550 (Luxury Package), 2006 C230 (Sport Package)
Location: Malabar, FL
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2007 E550 OBD II Fuse?

I have an intermittent check engine light on my 2007 E550, so I purchased an Actron CP9580 scanner to diagnose the problem. Unfortunately, there seems to be no power at the OBD port, the scanner won't power up. I immediately checked the scanner by connecting it to my Dodge pickup - works like a champ. When my wife returned home, I plugged in to her 2006 C230, and also works, so it's not a scanner not compatible with Mercedes issue. First thing I thought to do was check to see if the fuse protecting the OBD port was blown, but I can't find any documentation in the manual or in the car about which is the appropriate fuse.

Anybody know the location of the fuse that protects the OBD port?
srivet02 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 12-13-2011, 11:25 PM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
If it is a fuse issue, it would be fuse #36. But it could still be your tool issue, the W221 diagnosis connector is quite different from the W203, the W203 has power on more than one pin, the W221 only has power at pin #16.
Diesel Benz is offline  
post #3 of 8 (permalink) Old 12-14-2011, 05:45 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2011
Vehicle: 2007 E550 (Luxury Package), 2006 C230 (Sport Package)
Location: Malabar, FL
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, I'll specifically check fuse 36 tonight.... I thought all post 1996 models had to have the standard connector interface; I'm surprised there's differences from one model/platform to another. Also thought the 2007 E class was the W211 platform - is the platform different for the E320 vs. E550? I do appreciate you taking the time to answer, have had this car for almost 2 years, and this is really the first time I've had to dig in to a problem. Sorry if these sound like newbie questions, but I am, you know, a newbie to this......
srivet02 is offline  
post #4 of 8 (permalink) Old 12-14-2011, 05:46 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2011
Vehicle: 2007 E550 (Luxury Package), 2006 C230 (Sport Package)
Location: Malabar, FL
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Oh, and I'll put the DVM on the connector pins and see if I can verify which ones have power.......
srivet02 is offline  
post #5 of 8 (permalink) Old 12-14-2011, 07:09 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by srivet02 View Post
Thanks, I'll specifically check fuse 36 tonight.... I thought all post 1996 models had to have the standard connector interface; I'm surprised there's differences from one model/platform to another. Also thought the 2007 E class was the W211 platform - is the platform different for the E320 vs. E550? I do appreciate you taking the time to answer, have had this car for almost 2 years, and this is really the first time I've had to dig in to a problem. Sorry if these sound like newbie questions, but I am, you know, a newbie to this......
Sorry, my mistake, I was looking at S550 data (should use my spectacles).

On the E550 the fuse for pin #16 appears to be #30 (interior compartment, driver's side).
Diesel Benz is offline  
post #6 of 8 (permalink) Old 12-14-2011, 05:17 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2011
Vehicle: 2007 E550 (Luxury Package), 2006 C230 (Sport Package)
Location: Malabar, FL
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Yup, fuse #30 is open, I'll pick one up tomorrow, should be able to read diagnostic port then. Thanks for the help.
srivet02 is offline  
post #7 of 8 (permalink) Old 12-16-2011, 05:06 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2011
Vehicle: 2007 E550 (Luxury Package), 2006 C230 (Sport Package)
Location: Malabar, FL
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Replaced the fuse, read the code - P0015, (overretarded exhaust cam timing bank 1). Erased the code and drove today, no check engine light, and no code when I did the scan this evening....... guess it's nothing to worry about if I don't see it again......
srivet02 is offline  
post #8 of 8 (permalink) Old 12-16-2011, 08:12 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Right you are. Please post back if your CEL pops up again.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    known issues with 2007 E550? tights24 W211 E-Class 6 09-01-2013 10:36 AM
    What Nav DVD will work in my 2007 E550? kwbikr W211 E-Class 7 03-29-2009 11:01 PM
    2007 E550 polemid W211 E-Class 2 02-14-2009 04:48 AM
    E550 2007 Leaking oil. polemid W211 E-Class 3 09-14-2007 12:25 PM
    2007 E550 vs 00-02 E55 Power? Dawson AMG W210 E50 AMG, E55 AMG 7 09-13-2007 11:56 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome