1999 E320 odometer not working - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-03-2011, 05:00 PM Thread Starter
BenzWorld Newbie
Date registered: Nov 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question 1999 E320 odometer not working

Hello All, i am looking to purchase a 1999 E320 from a dealer. The odometer appears not be working, a common fault according to dealer. The service symbol is also showing. If the service symbol is reset will the odometer be revealed? Have searched forums for a solution and seek further guidance.

Has anybody got a solution?
Piperjnc is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-03-2011, 06:00 PM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,526
Mentioned: 9 Post(s)
Quoted: 1064 Post(s)
Welcome to the forum. Never heard about odometer problem on W210 models, but I did own only 3 of them
The odometer is digital on those cars , so is it the display not working or the counter not working? Resetting FSS is independent.
You are welcome to go to W210 section for wealth of informations about those cars.
BTW a business selling a car with past due service can be call lot of names, but "dealer" would be my last choice.
Kajtek1 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Trans Fluid leak near odometer connector, odometer stopped working and ASR light on. 92 500 Saunderklaus W140 S-Class 6 06-08-2010 03:16 PM
    1999 E320 "Lamp Defective" but all bulbs working vacant_lot W210 E50 AMG, E55 AMG 2 09-16-2009 08:24 PM
    Odometer light dim in 1999 E320 99e320sam W210 E-Class 1 08-17-2009 08:40 PM
    Odometer and Trip Odometer not working houston14 R129 SL-Class 1 05-27-2008 04:39 PM
    Odometer/trip odometer stopped working theratpatrol R/C107 SL/SLC Class 8 07-23-2005 08:12 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome