New member with ML 320 Blue tech issue - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-28-2011, 01:41 PM Thread Starter
BenzWorld Newbie
Date registered: Nov 2011
Vehicle: 2009 ML 320 Blue Tech
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New member with ML 320 Blue tech issue

I have a 2009 ML 320 Blue tech with only 5500 miles and have a chronic check engine light on. Dealership states I must flush the Blue tech tank and refill due to fluid not circulating due to low driving miles. Cost $250+ Has anyone had a simuliar issue??
Grex24 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-29-2011, 01:55 AM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,078
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    New Member With C 350 Issue Peter Zimmermann W204 C-Class 4 10-17-2011 08:27 AM
    Blue Smoke issue 500sl jwatkin2 R/C107 SL/SLC Class 15 09-30-2010 09:12 PM
    New member, MB tech miknik General Mercedes-Benz 1 02-14-2009 08:08 AM
    ML 2009 Blue Tooth issue W164 M-Class 4 12-06-2008 10:14 AM
    BLUE-TECH mileage report MRBSMITH W211 E-Class 45 01-24-2008 03:09 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome