Help! My car will not start. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-24-2011, 05:27 PM Thread Starter
BenzWorld Newbie
Date registered: Nov 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Help! My car will not start.

Happy Thanksgiving! Well on my day off I decided to replace the two fuel pumps and fuel filter on my 1990 190e. Both pumps were leaking and why not change all. Now it will not start. Anybody have any ideas?
jkong67 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-25-2011, 02:18 AM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,081
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld. Please complete your profile as this will help members give you the most accurate answer to your questions. Location is also important when we need to help you find parts etc. This forum is for introductions only and all questions should be posted on the appropriate sub forum for your car.

To edit your profile simply click on quick links “edit profile” (quick links is top Right of the page)

At the bottom of the page you will find forum jump, click on this and view all the available sub forums and there you will find the technical forum for your car.

For FAQ see the Benzworld help section here:
BenzWorld Help - - Mercedes-Benz Discussion Forum
Benzworld help is for general enquires and all technical questions should be posted on the specific forum for your car. If you are not sure which forum it should be on then please ask me and I will give you a link.



"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    G400 CDI 2002 - start, fails and wont start on cold 4444124 G-Class 14 10-20-2014 01:16 AM
    1989 300ce hard to start. When it does start has no power in gear. ddyke2000 W124 E,CE,D,TD Class 7 05-10-2011 07:42 PM
    1995 e320 Wagon - AC fails first start, fine on second start bwcole W124 E,CE,D,TD Class 3 05-18-2008 09:54 PM
    sl500 cold start fine-short trip park restart rough idle hard start?? dpol1835 R129 SL-Class 7 01-02-2006 06:33 AM
    Hard start or second start when warm high hc level-- beware major expense Peter Seow W126 S,SE,SEC,SEL,SD,SDL Class 1 07-03-2004 06:23 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome