New 300sd owner... but with some issues - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-17-2011, 07:56 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New 300sd owner... but with some issues

Just bought a 1984 300sd from a local guy with 188k on it. When i bought it i looked for common issues with smoke/ tranny/ coolant/ vacuum issues/ and electrical problems. Everything worked and it ran like a dream. ive owned the car for over a month now and the heater stopped working, doesnt even switch on when i hit the buttons, i think it may be the servo (makes a noise occasionally and sounds like a fan trying to get going). Secondly, the engines making a tapping/ popping noise on the passenger side, i hope that just means it needs the valves adjusted. theres a couple other minor issues but ill troubleshoot those later... any input about the heater and engine noise would be greatly appreciated.
fbmed is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-17-2011, 11:27 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld. Please complete your profile as this will help members give you the most accurate answer to your questions. Location is also important when we need to help you find parts etc. This forum is for introductions only and all questions should be posted on the appropriate sub forum for your car.

To edit your profile simply click on quick links “edit profile” (quick links is top Right of the page)

At the bottom of the page you will find forum jump, click on this and view all the available sub forums and there you will find the technical forum for your car.

For FAQ see the Benzworld help section here:
BenzWorld Help - Benzworld.org - Mercedes-Benz Discussion Forum
Benzworld help is for general enquires and all technical questions should be posted on the specific forum for your car. If you are not sure which forum it should be on then please ask me and I will give you a link.

Regards

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Issues with 93' 300SD Genscher W140 S-Class 3 11-01-2011 04:40 PM
    300SD A/C issues... Lain W126 S,SE,SEC,SEL,SD,SDL Class 0 08-03-2010 08:06 PM
    Hello, just got an 82 300SD and have some issues... the_Cowman W126 S,SE,SEC,SEL,SD,SDL Class 2 05-12-2008 07:28 PM
    A/C issues - '83 300SD Twizted W126 S,SE,SEC,SEL,SD,SDL Class 0 06-22-2004 10:49 AM
    300SD A/C issues H-TownBenzoboy W126 S,SE,SEC,SEL,SD,SDL Class 10 05-04-2004 10:00 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome