TEMP GAUGE BLUES - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-16-2011, 10:56 PM Thread Starter
BenzWorld Newbie
Date registered: Nov 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

Very confused about my 95 c280. My temp gauge is not reading. I've replaced all 3 sensors above thermostat on driverside front and my gauge cluster. Very stumped. Any ideas?
RedlineC280 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-17-2011, 01:19 AM
BenzWorld Senior Member
smart_guy's Avatar
Date registered: May 2010
Vehicle: W124 E300 12v 1992 and a 2009 Crown Victoria
Location: Saudi Arabia, Western Region
Posts: 539
Mentioned: 0 Post(s)
Quoted: 44 Post(s)
Did you check the connection between the sender and the gauge? Proving that the sender is one of the three censors you replaced.

Current vehicles:
1-MB W124 300e 12v 1992 +425k Km (daily drive)
2-Ford Crown Victoria 2009 (used when needed).

Previous vehicles:
Ford Crown Victoria 2001 (sold in early 2009)
MB W124 200 1986 (sold in late 2005)
MB W126 500 1986 (sold in late 2004)
smart_guy is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    brake lights, fuel gauge, temp gauge quit working badwin W201 190-Class 12 07-24-2015 06:55 PM
    Help! Right brake light, cruise control, fuel gauge, temp gauge, oil gauge out rsteckly W201 190-Class 1 09-27-2011 04:25 PM
    Temperature variance -- actual temp vs. gauge temp reading soundquest W124 E,CE,D,TD Class 7 06-19-2011 08:03 AM
    Problems fitting 500 fuel gauge-oil pres'-water temp gauge cluster to 560 clocks mutley666 W126 S,SE,SEC,SEL,SD,SDL Class 2 10-10-2005 09:03 AM
    When outside temp is higher than 40', how come the temp gauge still shows 40'? noelb W163 M-Class 5 04-16-2002 01:43 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome