need help pls - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-15-2011, 07:25 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 2003 ML 500
Location: Stoney Creek Ontario
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
need help pls

Hi all....new member here, just bought a 2003 ML 500 for my daughter at university (UWO, London Ontario)
the stereo just quit....seems to be power to the head unit, it lights up, but no sound, could it be the amp, and where is amp located. I searched forums and found a couple of answers, pls help!!

thanks

Al
ajd0002 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-15-2011, 08:51 AM
Sith Lord
 
elbeik's Avatar
 
Date registered: Sep 2009
Vehicle: 72 280SE 88 560SEC 92 E500 6.0 95 SL320 14 GLK350
Location: Beirut / Jeddah
Posts: 11,780
Mentioned: 3 Post(s)
Quoted: 217 Post(s)
Lifetime Premium Member
Garage
Welcome Al!

You might want to check fellow owners in the W163 M-Class - Benzworld.org - Mercedes-Benz Discussion Forum for your answers.

Don't forget to complete your profile with your car model and location
elbeik is offline  
post #3 of 5 (permalink) Old 11-15-2011, 10:15 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,614
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
 
post #4 of 5 (permalink) Old 11-16-2011, 05:28 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 2003 ML 500
Location: Stoney Creek Ontario
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks, looking forward to it!!
ajd0002 is offline  
post #5 of 5 (permalink) Old 11-16-2011, 05:34 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,614
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Quote:
Originally Posted by ajd0002 View Post
thanks, looking forward to it!!
You will find responses are better once you complete your profile, enjoy.

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome