HIGH Idle issue - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-14-2011, 09:05 AM Thread Starter
BenzWorld Newbie
Date registered: Nov 2011
Vehicle: 1990 420 SEL
Location: Northern Ohio
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
HIGH Idle issue

Hi my name is Jason
I have a 90 420 SEL
I was playing with the heater control valve behind the firewall trying to make my heater work. When I put everything back together the car now idles around 1500 - 1800 rpms. I checked the fuse in the OPV its fine. Is there something back there I may have knocked loose to cause this issue ?????????????
free4pf is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-15-2011, 04:29 AM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,075
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld and for best replies post your question in this forum;
W126 S,SE,SEC,SEL,SD,SDL Class - Benzworld.org - Mercedes-Benz Discussion Forum


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1991 420sel with a high idle and becker stereo issue lendicott General Mercedes-Benz 13 11-16-2010 05:44 PM
    I thought this hose went there! (High idle issue) decalservice W126 S,SE,SEC,SEL,SD,SDL Class 3 06-07-2010 05:18 PM
    Cold High Idle, Hot Hard start issue MBBoo R/C107 SL/SLC Class 27 07-29-2009 12:45 PM
    Another high idle & ABS light issue khimani_mohiki W126 S,SE,SEC,SEL,SD,SDL Class 3 06-28-2009 11:02 AM
    High Idle & CC light issue gikn W126 S,SE,SEC,SEL,SD,SDL Class 2 03-14-2007 06:28 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome