Help! Engine in limp mode, 3 of 4 injectors not opening... - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 16 (permalink) Old 11-18-2011, 09:33 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 1999 e320 RWD
Location: Calgary, AB
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Ok just updated my profile, thanks.

I'm in Alberta, Canada.

Interesting about the Magnaflow. I'm not sure if my cats to replace are rear or front.

I think I'll go with dealer for now (I want the car back asap and decrease chance of future problems/hassle), but next time the cat goes (hopefully in a long long time), I'll get aftermarket.

Funny that the left cat on my car was replaced in 2009. Now it's the right cat's turn. 280k kms on it.
hish123 is offline  
Sponsored Links
Advertisement
 
post #12 of 16 (permalink) Old 11-18-2011, 09:37 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: E320/E250 Bluetec R129 SL500 - $1300 car ........ Ford F350 6.7l
Location: V E G A S
Posts: 32,703
Mentioned: 10 Post(s)
Quoted: 1347 Post(s)
Cats don't usually go bad on their own. I still would suspect you have/had fuel dump into the exhaust to cost that.
Do you do smog test in Alberta?
Kajtek1 is online now  
post #13 of 16 (permalink) Old 11-18-2011, 09:54 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 1999 e320 RWD
Location: Calgary, AB
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Alberta does not seem to have smog testing. But Ontario does. I might move to Ontario one day.

So you're saying there might be a problem behind the cats going bad, and it's not just wear and tear? I did ask the dealer about that btw, they didn't have an answer, except to say well my car is '20 years old' (it's 12 years old lol!), so it's just old stuff wearing out...
hish123 is offline  
 
post #14 of 16 (permalink) Old 11-18-2011, 10:57 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: E320/E250 Bluetec R129 SL500 - $1300 car ........ Ford F350 6.7l
Location: V E G A S
Posts: 32,703
Mentioned: 10 Post(s)
Quoted: 1347 Post(s)
cats usually burn out, not wear out.
So yes, IMHO they could be the result, not the initial problem.
You should find "carburetor shop" who could run the engine test for optimal performance, or you can start DIY by putting new plugs, MAF and O2 sensors.
Doing those things you will get your money back on fuel savings, so no reason to hold on them if they are due.

Last edited by Kajtek1; 11-18-2011 at 10:59 AM.
Kajtek1 is online now  
post #15 of 16 (permalink) Old 11-19-2011, 09:09 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 1999 e320 RWD
Location: Calgary, AB
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Ok thanks. I will check on that.

I did replace the spark plugs 4 months ago, the old ones were there beyond the time they were due I believe, so that may have contributed.
hish123 is offline  
post #16 of 16 (permalink) Old 11-20-2011, 11:12 AM
BenzWorld Junior Member
 
Mar L. Barruel III, MBA's Avatar
 
Date registered: Feb 2008
Vehicle: 2005 ML500, 1999 C230 KOMPRESSOR, 1993 300E, 1964 220SE, 1994 E320, 2001 E320 4MATIC, 1991 380SEL
Location: ALEXANDRIA, VIRGINIA
Posts: 47
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
A clogged Catalytic Converter can cause a misfire!

I'M A FACTORY-TRAINED MERCEDES-BENZ MASTER SYSTEMS TECHNICIAN, ASE (AUTOMOTIVE SERVICE OF EXCELLENCE) MASTER AUTOMOBILE TECHNICIAN, BOSCH MASTER TECHNICIAN, MECP (MOBILE ELECTRONICS CERTIFIED PROFESSIONALS) MASTER TECHNICIAN, AND A L1 ASE & BOSCH ADVANCED ENGINE PERFORMANCE SPECIALIST WITH A MASTER'S IN BUSINESS ADMINISTRATION.
Mar L. Barruel III, MBA is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
ABS- ESP- Engine light- limp mode after car wash tbrown W211 E-Class 8 11-07-2013 09:36 AM
Falling in Limp Mode Again With No Check Engine Light?? ZEvans W163 M-Class 18 07-30-2011 09:04 AM
E320 Check Engine light-Limp Mode? Transmission? jchumba General Mercedes-Benz 5 11-01-2008 05:03 PM
E320 Check Engine light-Limp Mode? Transmission? jchumba W210 E50 AMG, E55 AMG 3 10-25-2008 10:54 AM
E320 Check Engine light-Limp Mode? jchumba General Mercedes-Benz 1 10-25-2008 08:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome