c220 cdi intermittent problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-05-2011, 07:02 AM Thread Starter
BenzWorld Newbie
Date registered: Nov 2011
Vehicle: 2005 Mercedes c220 cdi sport edition
Location: Cardiff
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
c220 cdi intermittent problem

Hi All, Here's my story. I have and love to death my c220cdi auto sport edition.
I've had it for 6 months and it's a 2005 model having covered 141k with full merc history. Since I've had it it's had 2 issues:-

1. It runs very well, pulls like a train ( 150bhp ) and is very smooth. Then it starts almost pinking with a rattle that sounds like it's coming from the bowels of the engine, then it goes and a while later it comes back. I had a week recently where it didn't do it and then it came back. During a 30 minute journey around town it will do this 3 or 4 times, or not at all. I cruised recently for 5 hours at 75mph and it didn't miss a beat then as soon as I came off the motorway it started again then stopped.

2. There is a thumping noise especially when going over bumps and only when my foot is on the accelerator coming from the transmission tunnel, sounds like something is loose.

So far I've been to 4 garages and 2 Merc specialists who have come up with the following:

1. Diagnostic show nothing wrong.
2. DPF furry----However it doesn't have one.. And that's a specialist.
3. Gearbox contamination.
4. Injector faulty.

I'm getting very frustrated as no one seems to be able to diagnose the fault as when they drive it it's all fine, however when I drive it away from the garage it starts creating again. Also the fuel consumption can vary from 25-40mpg for the same journey but on different days.

Tell me I'm not having a breakdown and please help!!!!!!
locktock06 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 11-06-2011, 12:31 AM
Sith Lord
elbeik's Avatar
Date registered: Sep 2009
Vehicle: 72 280SE 88 560SEC 92 E500 6.0 95 SL320 14 GLK350
Location: Beirut / Jeddah
Posts: 11,763
Mentioned: 3 Post(s)
Quoted: 212 Post(s)
Lifetime Premium Member
Hello, and welcome aboard.

You'll find answer to your queries in the C-class section; W203 C-Class - Benzworld.org - Mercedes-Benz Discussion Forum
This where expert members mostly spend their time and will provide you with helpful advice.

Good luck!
elbeik is offline  
post #3 of 3 (permalink) Old 11-06-2011, 10:10 PM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,072
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Intermittent problem going from R to D chucelli W210 E-Class 11 05-07-2011 04:50 AM
    Next intermittent problem Wannabe2 V-Class 7 04-24-2011 08:24 AM
    C220 CDI Intermittent Power Loss Cab262 W203 C-Class 1 05-04-2010 04:06 AM
    Intermittent Problem... Lukey97 W202 C-Class 3 11-03-2008 04:41 PM
    Intermittent VES problem........ ed W163 M-Class 1 07-23-2005 10:22 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome