1995 w140 S600 Coupe ASR limp problem - DTC codes - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-27-2011, 03:21 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2010
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1995 w140 S600 Coupe ASR limp problem - DTC codes

Hello,

I've got a 1995 s600 coupe. The ASR has been intermittent and comes on and goes to LIMP mode more frequently now (daily). I turn ignition off and on and sometimes it works or not.

I have the LED push button stock setup near next to the CAN modules (California vehicle). I pressed it and got 6, 9, 19 and 38 blinks. How do I find out what these codes mean???

Is it possible that my ETA is the problem?
I've recently replaced the upper fuel injector wiring harness, but no change for anything, but those wires were looking bad anyway. The car appears to have a small misfire, but I haven't narrowed that down yet Otherwise, this is a nicely kept car with 98,000 miles on it.

What's causing ASR limp and what are those codes indicating?

Thank you!
the marshal is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-28-2011, 02:28 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,590
Mentioned: 3 Post(s)
Quoted: 311 Post(s)
Please add your car to your profile and welcome to Benzworld

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #3 of 4 (permalink) Old 10-28-2011, 01:34 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2010
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, I''l get some pics added shortly.

Today, I simply decided to erase DTC codes using the simple led push button that's attached to the car. I believe it only reads Fuel injection info. Anyway, after erasing codes the car is not going into LIMP/ASR (drives great), however I done this before and only lasted a day or two as the computer will relearn whatever problem is causing it.

Before resetting, I wrote down the number of blinks. 6 and 38. Can anyone tell me what that means? especially 6 as I've heard that 38 is unused.

Thanks
the marshal is offline  
 
post #4 of 4 (permalink) Old 11-22-2012, 02:46 PM
BenzWorld Junior Member
 
Date registered: Oct 2011
Posts: 23
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
ASR LIGHT

Quote:
Originally Posted by eric242340 View Post
Please add your car to your profile and welcome to Benzworld
i had the same problem few months ago. pls. do not take your car to any road side mechanic because they cannot fix ur problem. mine was at a road side mechanic for 29 days under that intense california sun. later they called me to say "we ordered the parts and will take 2weeks to arrive" we will call u as soon as we get the parts. checked with them for 3 wks still no parts, then i took it to walters in riverside and they got my car ready the second day. and how much? $300.00
OMOYANGHEDE is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Help with codes ASR limp home 1995 s320 jedovaty W140 S-Class 1 05-02-2011 09:33 AM
Low Mileage 1995 W140 S600 Coupe...Full of Gremlins! Need Help Guys! caddykingaz W140 S-Class 23 02-10-2011 05:47 PM
1995 S600 Coupe vs 2008 Bentley Continental GT Coupe Stryker-1999 S600 W140 S-Class 21 11-09-2010 10:25 AM
About to buy a W140 1995 S600 coupe SteinwaySteve W140 S-Class 10 10-06-2010 06:59 PM
1995 S600 Limp Mode After Battery Reset npatel219 W140 S-Class 2 06-04-2010 07:12 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome