05 Sprinter shifter troubles. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-22-2011, 05:12 AM Thread Starter
BenzWorld Newbie
Date registered: Oct 2011
Vehicle: 2005 Dodge Sprinter 2500, 158" wheel base High top.
Location: Vero Beach, FL
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Skype™ to jcweller1
(Thread Starter)
Exclamation 05 Sprinter shifter troubles.

HI all. I posted the other day about issues with my sprinter related to an overheat etc. I get it back from the shop and it wouldn't start unless I wiggled the shifter. This was in intermittent problem until last weekend. Since then I have replaced the shifter with a new Mercedes unit from the local Dodge dealer. I was told by the parts department that Mercedes has had massive issues with this style of shifter and that the dealership had to replace the shifter in their Sprinter as well.
A year ago I replaced the brake switch as I was getting ABS lights and all the other lights that the switch controls. At that time I also couldn't shift the van into gear without tripping the park lock. Replacing the switch worked well and I have had no problems until this shifter issue. Most of the time I turn the key and the engine won't turn over. Sometimes if I try it a few time it works. Other times I have to wiggle the shifter in the park position or even trip the park lock to allow me to shift to neutral to try to start it.
After replacing the shifter assembly, all worked fine for 2 days. Now I'm back to the same issues and not knowing when I will have troubles starting the van. I have made sure the trans shift linkage is adjusted properly. I have taken all the wiring connectors and cleaned them with contact cleaner to be sure there isn't a corrosion issue.
Another foreign car tech told me yesterday that the new shifter could be the issue as he has seen them faulty right out of the box.
If any one has any ideas I sure could use the guidance.

Thanks in advance,
jcweller1 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 10-22-2011, 06:09 AM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
If you don't mind clarifying, it starts every time in neutral, but not in park, correct? Also, when it's not starting in park, you have difficulty getting it into neutral at the same time or are those separate problems?

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #3 of 3 (permalink) Old 10-22-2011, 06:29 PM Thread Starter
BenzWorld Newbie
Date registered: Oct 2011
Vehicle: 2005 Dodge Sprinter 2500, 158" wheel base High top.
Location: Vero Beach, FL
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Skype™ to jcweller1
(Thread Starter)
It will sometimes start in park if I wiggle the shifter. When it doesn't start in park I have to trip the park lock and shift into neutral, but that doesn't always mean it will start. Sometimes I have to play with the shifter in park and neutral.
This morning it started fine in park. After reading some other posts I decided to re-adjust the trans shift cable. I shortened it by about 1/8th of an inch and it has worked fine all day. Now this evening I started it and took off and all the ABS, ESP and Brake warning lights came on. The brake lights work. I shut it down and restarted and drove off with no more lights? HMMMM The trans shifter cable adjustment fixed the starting problem. At least for the present. I shall see what happens with a few days of driving.


jcweller1 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    New Guy With 05' Sprinter Shifter Troubles jcweller1 General Mercedes-Benz 1 10-18-2011 07:49 AM
    A/C troubles 79Mercy W123 E,CE,D,CD,TD,TE Class 0 06-25-2007 09:25 PM
    OIL troubles...what should I do ? mbeclass W124 E,CE,D,TD Class 5 07-23-2006 08:08 PM
    Ultimate Windsurfing Van - Freightliner Sprinter Van Dodge Sprinter Saigon76nyc W901-905 Sprinter 3 10-06-2005 11:17 AM
    Help! Having car troubles... Patrick R170 SLK-Class 8 02-18-2002 08:51 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome