2002, S 55 AMG with mechanical or computer issues? - Page 2 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #11 of 13 (permalink) Old 10-12-2011, 07:20 PM Thread Starter
BenzWorld Junior Member
Date registered: Oct 2011
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Originally Posted by DirectLA View Post
Also check condition of battery since a low charge on an old unit could cause similar issues as these.
battery is solid .....thanks thou, any ideas
jeffreyleech is offline  
Sponsored Links
post #12 of 13 (permalink) Old 10-12-2011, 07:30 PM
BenzWorld Elite
DirectLA's Avatar
Date registered: Jan 2007
Vehicle: 1962 W111 220SE Coupe
Location: Cloud City, OR
Posts: 2,289
Mentioned: 1 Post(s)
Quoted: 8 Post(s)
To Flyboyike's suggestion, I know you said your posts are tight but have they been cleaned in any way, ideally with the purpose-built wire brush for battery posts and terminals? Maybe electrical contact grease wouldn't hurt. There could still be corrosion/oxidation on the surface that is preventing adequate contact.


The Coupe Group (W111/112 coupes and cabs)official website
The Coupe Group on Facebook

"Too many people are working at jobs they hate, to buy things they don't particularly want, to impress people they don't even care about." --Dr. Deepak Chopra
DirectLA is offline  
post #13 of 13 (permalink) Old 10-13-2011, 10:21 AM Thread Starter
BenzWorld Junior Member
Date registered: Oct 2011
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
It was the ground .....thanks for everones help , was loose
jeffreyleech is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Need Computer 2002? esqmock G-Class 12 04-22-2010 06:20 PM
    2002 G-500 computer related faults? Sailor7777 G-Class 14 02-28-2010 03:38 PM
    Computer Issues CIG3 W210 E-Class 2 12-01-2008 08:09 AM
    2002 Trip Computer problems? Harvey W163 M-Class 6 11-26-2001 01:51 PM
    NE1 else have a 2002 with bad trip computer? Stanley W163 M-Class 3 11-06-2001 11:48 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome