2000 vito replacement engine problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-07-2011, 04:40 AM Thread Starter
BenzWorld Newbie
Date registered: Jul 2011
Vehicle: Vito 2000 110CDi
Location: East Lancs, UK
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2000 vito replacement engine problem

Hi All,

Got a cdi110 that needed a replacement engine. Done. And it works... except there is a distinct lack of power to the point of having to change down to 4th when going up hill on a M'way. And when I change up gear, its like any momentum that the engine carried is lost and it has to build it revs up from scratch.

Anyway, 2 professional turbo companies have diagnosed the the turbo is ok and gets up to pressure (eventually). When I floor the throttle I get a lot of black smoke, more than you usually get from flooring a diesel.

It still sounds like a turbo fault but I cant argue with the diagnostics.

I have also changed the clocks as I have heard they could be at fault but no change.

Do my injectors need calibrating to the ECU or something? What else could the problem be?
NiceWheels is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-08-2011, 04:33 AM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,064
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
You would do far better asking your questions on the forum in this link;

V-Class - Benzworld.org - Mercedes-Benz Discussion Forum


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Vito 108cdi Engine problem maybe? scouseiron69 V-Class 14 12-31-2012 03:37 PM
    vito 110cdi van year 2000 x where is the fuse for the engine cooling fan stumpy231 V-Class 2 04-25-2011 06:56 AM
    problem wobbly handling vito 110cdi 2000 reg mick2a V-Class 7 10-20-2009 12:01 PM
    problem with codiren vito cdi 2000 josip77 V-Class 0 11-05-2005 11:20 AM
    Vito 108D 1999 Engine Problem Steve Mow V-Class 3 01-12-2005 09:43 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome