c class 220 cdi sport coupe starting problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-05-2011, 09:33 AM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2011
Vehicle: mercedes benz c clas 220cdi sport coupe with automatic gear box
Location: IRELAND
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
c class 220 cdi sport coupe starting problem

Hi everyone,
I haw Mercedes Benz C class 220cdi sport coupe.
My Mercedes takes up to 30 seconds sometimes up to 1 minute to start but when it does start it runs great (no performance problems). Sometimes it starts without any problem for few days (takes only few seconds to start), and then it’s difficult to start again (it’s difficult to start after every stop). I had a mobile tune come to my house he plugged in and no fault codes came up. The only thing he found was when you turned engine on is low fuel pressure, but then the engine starts the pressure is ok. His checked injectors and all 4 piston pressure in crankshaft and the pressure was ok. I hew already changed fuel filter. But no any difference after that.
Other problem, which happened few times is when you drive on motorway and you accelerating normally everything is ok, but if I want to pass someone quickly, and I hit a gas to the bottom, car accelerates for few seconds and then engine just shuts down totally, when I hew to stop and restart engine and I can drive again (the fault massage which comes up is EPC, (something that engine is not enough power)) PS. The car is with automatic gear box.
On standstill I can accelerate car to 5 rpm no problem, on motorway I can drive 200km/h no problem, car is working fine.
My idea was that something wrong is with diesel pump, it don’t gives enough diesel pressure when I want to start car, so that is why it’s difficult to start, and has not enough diesel pressure when I accelerating hard (not giving that boost of diesel)
So, please help me with this 2 problems
nierkazauras is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-05-2011, 10:58 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,754
Mentioned: 9 Post(s)
Quoted: 1119 Post(s)
Welcome to the forum. Indeterminate problems can be a nightmare to pinpoint, but your car should have advanced diagnostics.
Beside fuel pump acting, the other possibility is that the injector is having internal leak and dumps fuel back to the tank not allowing the pressure to build up. Check if you have engineering mode on your car that would allow you to monitor fuel pressure during start up and driving.
Other option to pinpoint bad injector is to use infra red thermometer and compare the cylinder temperatures. Accessing the head on modern engines gets harder and harder, but measuring the exhaust close to cylinder will work as well.
Good luck.
Kajtek1 is online now  
post #3 of 4 (permalink) Old 10-05-2011, 12:25 PM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
I believe this car is old enough to have problems with o-rings at the low pressure fuel lines at the engine compartment. You should check if there are any air bubbles in the low pressure lines (if necessary, replace a hose to a transparent one).

Another typical issue is injector leak, making the rail pressure remain too low and the ECU does not start injection in that case. You may try to unplug the pressure sensor from the rail, just to start the car (in this case the ECU does not wait for sufficient rail pressure but starts injection immediately and most often the car starts even at "too low" rail pressure).

You can test injector leak with a set of transparent tubes attached to each of the return line and measure the quantity and compare injectors if they have the same amount of leak.

I'm not familiar with this engine but the fact that the engine dies at speed may come from injector wiring issues or it could be something completely different like a peak at some sensor reading, I've seen the EPC (Electronic Power Control) message mentioned several times but I cannot remember the typical reason for this).

Last edited by Diesel Benz; 10-05-2011 at 12:28 PM.
Diesel Benz is offline  
post #4 of 4 (permalink) Old 10-05-2011, 01:12 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2011
Vehicle: mercedes benz c clas 220cdi sport coupe with automatic gear box
Location: IRELAND
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks for info

thanks guys for info, I will look at this straight away
by the way, maybe some of you know where I can download this cars fuel systems diagram, that wood be really helpful to me working on this problem
nierkazauras is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1994 S600 coupe "Vacuum assist pump problem and now a starting problem Bigpauly52 W140 S-Class 18 09-26-2004 01:36 AM
    [NEWSFLASH] New C-class Sport models unveiled! C230K sedan, C320 Sport Coupe & C-class 4-matics Drew W203 C-Class 17 01-06-2003 11:44 PM
    When will C-class sport coupe be avaliable ? Guest (MBNZ) W203 C-Class 3 06-07-2001 09:00 AM
    OT: For those interested in the C-class sport coupe... Brian R170 SLK-Class 0 05-09-2001 09:28 AM
    OT: C Class Sport Coupe AMG Joe R170 SLK-Class 12 05-08-2001 07:13 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome