cdi starting problems...nightmare - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 10-01-2011, 07:59 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
cdi starting problems...nightmare

I have smart but all this is the same so I put this question here.
help me, I am crazy with car.

SO, I have smart cdi, 2003, 60000miles. Before 4 month I drive on freeway for one hour, speed 120kmh, outside temp around 28C-hot day. Engine get hot to 120C, so I cool it down and turn off for 10 minutes. When I try to start engine, starter turn over but no fire up. After 20 times cranking engine start with allot black smoke. To this days, I CANT START ENGINE NORMALLY. No smoke, no nothing, but when running idle is perfect, run perfect, never stall. Symptoms: starter turns but no crank. Last two days in the morning outside temp is around 14C and engine start fine but after several minutes driving no start again. Sometimes I can recognize little and several air bubbles in fuel lines but this is not reason for hard starting like this.
I check:
1. compression test, 16bar, 26bar, 26bar
2. computer diagnostics OK
3. battery OK
4. starter OK
5. new camshaft sensor
6. injectors tested and is like new (both injection and return)
7. no smoke
8. power OK
9. no oil consumption
10. fuel pressure at idle 240bar, on turn over 370bar (OK i think)
11. new fuel filter
12. new air filter
13. new termostat

What to do people??? I am crazy, I check everything, my pocket is empty.
This low compression on one cylinder is last thing but why engine sometime start ok even is hot???

if someone really want to help me here is another thread on smart forum:
cdi starting problems - smartmaniacs

thanks thanks thanks
foler is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 10-01-2011, 10:43 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,785
Mentioned: 9 Post(s)
Quoted: 1127 Post(s)
The compression between cylinders show big differences. I hope this is not the reason. Recheck it and do cold and hot test if you can.
Air in the fuel lines is not helping for sure. .... especially if the fuel drains from the pump on hot engine.
BTW we have been advocating for diesel section on this forum with a big NO from administrator, so this is proper section for posting diesel problems to get reviews from owners of the same engines in different models.
Kajtek1 is online now  
post #3 of 16 (permalink) Old 10-01-2011, 10:34 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
yesterday car started 4 times with no problems, hot and cold. today in the morning started ok, in evening again problem. Compression is physical constant, so engine cant have one day good compression and other day low compression. I think that injectors dont inject fuel into cylinders but how to check this???
foler is offline  
post #4 of 16 (permalink) Old 10-02-2011, 10:44 PM
BenzWorld Member
 
Date registered: Nov 2010
Vehicle: 2000 S320
Location: Sydney, Australia
Posts: 132
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by Kajtek1 View Post
The compression between cylinders show big differences. I hope this is not the reason. Recheck it and do cold and hot test if you can.
Air in the fuel lines is not helping for sure. .... especially if the fuel drains from the pump on hot engine.
BTW we have been advocating for diesel section on this forum with a big NO from administrator, so this is proper section for posting diesel problems to get reviews from owners of the same engines in different models.
FULLY AGREE - WE NEED A SEPARATE DIESEL SECTION
benparson is offline  
post #5 of 16 (permalink) Old 10-03-2011, 01:00 AM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,699
Mentioned: 1 Post(s)
Quoted: 68 Post(s)
Quote:
Originally Posted by benparson View Post
FULLY AGREE - WE NEED A SEPARATE DIESEL SECTION
Yeah, it's called the W123 section. Most of those guys wouldn't know gasoline if you drenched them with it and struck a match.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #6 of 16 (permalink) Old 10-03-2011, 10:16 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,785
Mentioned: 9 Post(s)
Quoted: 1127 Post(s)
Quote:
Originally Posted by foler View Post
yesterday car started 4 times with no problems, hot and cold. today in the morning started ok, in evening again problem. Compression is physical constant, so engine cant have one day good compression and other day low compression. I think that injectors don't inject fuel into cylinders but how to check this???
Injection has no effect on cylinder compression. You have bad valve, or piston rings.
Those can create havoc with engine management.
How is the blowby?

Last edited by Kajtek1; 10-03-2011 at 10:19 AM.
Kajtek1 is online now  
post #7 of 16 (permalink) Old 10-03-2011, 12:48 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Kajtek1 View Post
Injection has no effect on cylinder compression. You have bad valve, or piston rings.
Those can create havoc with engine management.
How is the blowby?
Maybe when engine is at 120C before several months. I turned it off to cool down and that is big mistake. I will try to repair this one cylinder.
foler is offline  
post #8 of 16 (permalink) Old 10-21-2011, 12:44 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
SAGA IS ended. RESOLVED. My valves seats is destroyed and engine cant have good compression. This is reason for hard starting. So, I repair cylinder head, new piston rings, rod bearings, oil....and now engine work properly. I spend almost same money for trying to identify problem and for rebuild. Uhhh, big mistake. I never will have again diesel engine.

Please, mark this thread RESOLVED.
foler is offline  
post #9 of 16 (permalink) Old 10-21-2011, 02:10 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,785
Mentioned: 9 Post(s)
Quoted: 1127 Post(s)
don't judge all diesels by one bad apple.
MB diesels are famous for running million miles on them, but Smart is not a Mercedes design from what I heard?
Kajtek1 is online now  
post #10 of 16 (permalink) Old 10-21-2011, 02:25 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Kajtek1 View Post
don't judge all diesels by one bad apple.
MB diesels are famous for running million miles on them, but Smart is not a Mercedes design from what I heard?
I dont want diesel anymore in my life because in common rail diesel engines everything is about high pressure and many parts can go wrong and all cost $$$ (pressure pump, injectors, seals, pipes...). Gas engine is much easy to deal with it because here is 100x lower fuel pressure, 2.4x lower compression, simple spark plugs etc etc...
All diesels share same engine principe and all have same problems. My is resolved.
foler is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    ML CDI starting problems zak W164 M-Class 2 01-09-2008 03:12 PM
    Stored 1993 S420 has fuel problems-Gives sudden starting problems-solution needed heartmd W140 S-Class 15 12-09-2007 02:45 PM
    Starting Problems saabcm W140 S-Class 6 03-10-2007 02:26 PM
    starting problems ChromeImages C208/A208 CLK-Class 2 07-18-2005 04:33 PM
    anyone have starting problems? My car died twice today after starting... cgeorge430 W163 M-Class 10 08-03-2002 11:57 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome