1989 300 CE Suddenly Craps Strands Me - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-18-2011, 11:33 PM Thread Starter
BenzWorld Junior Member
Date registered: Sep 2011
Vehicle: Current: 91 350SD, 89 300CE /Former: 80 280SL Euro, 79 300SD, 80 280E, 82 300TDT Euro, 82 300D Turbo
Location: Floral City Florida
Posts: 29
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1989 300 CE Suddenly Craps Strands Me


I just picked up an 89 300CE because it is low to the ground and my mother having been diagnosed with uterine cancer cannot get up into my 350SD or my CR-V. The car on most points was very good for the 2100 US I paid for it. Add in another hour to my most excellent mechanic to adjust and replace the ECH, it still was stuttering, so he ordered me a new cap and rotor (we had already replaced the plugs with the OEM from Mercedes Benz of Monterey), and the car still started roughly, but smoothed out and started readily after reaching operating temp. On my mechanics advice I put a new 86C thermostat (from a '76 240D, because the seals match) to replace the 106C Chinese thermostat that was in place. Good thing we caught this early. Even after all this it was rough on cold starts so my parts Mgr from MB Monterey sent me a new OVP. After this was installed the car ran fine for a day and a night, with many shut downs and startups, heatups and cooldowns. However the next day I was heading out to town and saw a 560SEC on the roadside with flashers on so I u-turned and stopped to 'help'. By the time I shut my 300CE off and walked to his car to find out he was merely making a 'cellphone call' and back my car wouldn't start. Ignition coil is fine. I have info that the pins in the fuel pump relay can be crossed to eliminate the relay. My parts Magician could only say that is was pins 7 and 8. All I see on the relay are two pins marked 87L. Could that be what he meant? I do not want to start throwing parts at the car without some advice, can anyone, or has anyone, ever seen this pattern before? HELP S>O>S I cannot use my 350SD around town it is the Highway Car and had just about eveything replaced on it down to the strut rod bushings, turbo, vacuum pump, 4 calipers, everything works on it but you all know it is a trip car, not a runabout, and right now I could use some da--ned good advice. Forgive my new-bee-ism, just answer with your knowledge, PLEASE.
Marinecraft is offline  
Sponsored Links
post #2 of 2 (permalink) Old 09-19-2011, 03:14 AM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
Try the W124 forum.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1989 260E Dies Suddenly, Need Help! StevenBarci W124 E,CE,D,TD Class 6 10-19-2010 02:49 PM
    Moonie Paper craps out. Who will the BWOT RWNJ's quote now? FeelTheLove Off-Topic 36 12-08-2009 04:50 PM
    A/C Blowing Hot Air - Suddenly Skylaw R/C107 SL/SLC Class 14 10-17-2009 08:27 AM
    Suddenly! Haroundb W140 S-Class 10 11-23-2008 05:39 AM
    My V8 is suddenly now a V7 - help please... shrimpton W126 S,SE,SEC,SEL,SD,SDL Class 11 04-14-2003 02:38 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome