Will my car start up with the MAF taken out? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-16-2011, 03:57 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2011
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Will my car start up with the MAF taken out?

Hi guys

My car refuses to start up.. i found out that this is because of the mass air flow sensor. I have removed the MAF but when i tried to start the car up, it still doesnt start. Is this normal? Does the car require a new MAF for it to start up, or does this mean that theres something else that wrong with the car. Its a 2007 C180 kompressor (W203)> can anyone help?
Mitesh is offline  
Sponsored Links
post #2 of 3 (permalink) Old 09-16-2011, 07:34 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
If it starts with a MAF it should start without it. Since your does not, I think something else must be wrong. What are the OBD2 codes?

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 3 (permalink) Old 09-16-2011, 08:19 AM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,531
Mentioned: 9 Post(s)
Quoted: 1070 Post(s)
Engine working with MAF disconnect is not confirmed on all models. Computers do have default mode to switch if they sense bad MAF, but this takes time to engage.
Bottom line, when it comes to computer programming -take nothing for granted.
Kajtek1 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    G400 CDI 2002 - start, fails and wont start on cold 4444124 G-Class 14 10-20-2014 01:16 AM
    1989 300ce hard to start. When it does start has no power in gear. ddyke2000 W124 E,CE,D,TD Class 7 05-10-2011 07:42 PM
    1995 e320 Wagon - AC fails first start, fine on second start bwcole W124 E,CE,D,TD Class 3 05-18-2008 09:54 PM
    sl500 cold start fine-short trip park restart rough idle hard start?? dpol1835 R129 SL-Class 7 01-02-2006 06:33 AM
    Hard start or second start when warm high hc level-- beware major expense Peter Seow W126 S,SE,SEC,SEL,SD,SDL Class 1 07-03-2004 06:23 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome