Help...no instrument lighting in my ML320 W163 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-15-2011, 04:31 PM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2011
Vehicle: ML 320 W164
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Help...no instrument lighting in my ML320 W163

Hi everyone,
I wish to pick your collective minds to help solve a problem I have with my 1999 W163 ML320.
I have lost all internal instrument lights......clocks, dials and buttons...nothing. I have checked the fuses and all appear to be ok...maybe I am missing something??
All external lighting is working fine
Please help

Warmest regards

Private Pyle
private_pyle is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-15-2011, 06:05 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,282
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
Just to make sure, did you check both fuse boxes? There is the one under hood and one inside on the passenger side. If memory serves me correctly, there is a fuse for the instrument panel in there.

You can also search or post this on the w163 forum as well. Might get some ideas there too.

Mike
Michael Pillay is offline  
post #3 of 3 (permalink) Old 09-16-2011, 01:29 AM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2011
Vehicle: ML 320 W164
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
SOLVED !!

Mike...your a legend...I had no idea there was a box on that side...thank you !!!!!!
private_pyle is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Instrument Lighting mlbage R170 SLK-Class 17 11-26-2010 07:05 PM
    Instrument Lighting NC_Mike W140 S-Class 3 04-20-2007 03:39 AM
    instrument lighting 67mcqueen W124 E,CE,D,TD Class 0 01-13-2007 10:53 AM
    Instrument lighting Bob M R170 SLK-Class 3 05-19-2003 05:25 AM
    instrument lighting 82 SD Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 2 03-24-2002 06:33 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome