osshdad - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-12-2011, 05:54 AM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2011
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question osshdad

I have a 2005 CLS350 which I thought was a magic car until last week when it suddenly started to get stuck in 3rd gear (G7 auto), 50.000Km's and just out of 6 year Motorplan. The problem is intermittent. MB service provider tells me it is a valve which has to be replaced at a cost of $2500.00 plus labour costs.

Is this a common fault with this model???

Does this valve have to be replaced or is there an alternative??
osshdad is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-12-2011, 06:01 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,194
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Quote:
Originally Posted by osshdad View Post
I have a 2005 CLS350 which I thought was a magic car until last week when it suddenly started to get stuck in 3rd gear (G7 auto), 50.000Km's and just out of 6 year Motorplan. The problem is intermittent. MB service provider tells me it is a valve which has to be replaced at a cost of $2500.00 plus labour costs.

Is this a common fault with this model???

Does this valve have to be replaced or is there an alternative??
With the 7Gtronic transmission there have been many valve body and control unit problems. It is fitted to many benz models and all are reporting faults. The valve body has been modified 4 times to my knowledge and still the reports come in. You will have to change the parts, sorry to say this.

But your car is at 50k, was the transmission fluid and filter changed at 39k as per benz recommendation?

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #3 of 3 (permalink) Old 09-12-2011, 11:21 AM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2011
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Eric, yes oil and filter were changed at 40,000km's. MB are offering me a 30% reduction on part to be replaced which I am not at all happy with. I also have a 2003 SL500 with 87,000Km's on the clock, last month the dual steerin/hydraulic suspension pump popped a seal, they wanted to replace the pump at a cost of $4,500 plus labour etc. I queried the availability of a seal and O ring kit, their reponse was "no such kit is available from MB...you have to replace the pump. I took it to a local hydraulic pump repair shop, they replaced the blown seal and 4 O rings for $400.00....so much for MB, my next car will be a BMW which I drove for many years, many different models without any problems and excellent after sales service.
osshdad is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome