Dualtone Horn on Mercedes E320 Avantgarde now only single tone..HELP PLEASE!! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-04-2011, 12:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2011
Vehicle: E320 AMG 2004
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Dualtone Horn on Mercedes E320 Avantgarde now only single tone..HELP PLEASE!!

Hi all,

HELP !!

My Mercedes E320 Avantgarde sounds like one of those old Citroen 2CVs when I press the steering wheel button..!

I haven't had the car long (3 months) the horn worked fine before, but it has suddenly gone from being a rather menacing sounding horn (dualtone) to a feeble sounding singletone horn that would be more fitting if it was used by someone who owns a bicycle with a wicker basket attached!

I love my car but I don't love the sound the horn makes anymore!!

Any ideas anyone on what's happened and how to fix it??

Thanks in advance
built2last is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-04-2011, 01:56 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,756
Mentioned: 9 Post(s)
Quoted: 1120 Post(s)
Sounds like low tone horn gave up. Not uncommon on vehicles with +- 10 year of age.
The horns on our MB work fine, but my truck had the same problem you do. The horn is buried under the fender, so not worrying about it, I added this baby to the setup.
On sale for $9.99 in US
http://www.harborfreight.com/100-db-...orn-96291.html

Kajtek1 is offline  
post #3 of 4 (permalink) Old 09-05-2011, 12:44 PM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2011
Vehicle: E320 AMG 2004
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks friend

considering I only bought the car recently I was hoping this horn fault wouldnt mean having to buy a new unit for it. Im in the UK and the car is 7 years old. Since posting and reading your reply though I've read a few threads on similar cases and it seems it might be a common fault..

I'm no mechanic but I wondered if it was a case of a blown fuse? a wire that had come undone? (last one was wishful thinking)

But if it means buying and having a new unit installed then I guess I got to pay up..
built2last is offline  
post #4 of 4 (permalink) Old 09-05-2011, 01:01 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,756
Mentioned: 9 Post(s)
Quoted: 1120 Post(s)
Usually both horns operate on the same wire, so if you have one working and other not - it has to be defective. This is not expense you will have to mortgage your house for. Wish we only had such problems with our cars.
Kajtek1 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    High Tone Replacement Horn valmomo69 W251 R-Class 0 12-01-2010 04:46 PM
    Horn tone enviedenigma W220 S-Class 8 02-28-2010 03:02 PM
    So, I got a new low-tone horn from the stealership today koaea R170 SLK-Class 8 04-12-2008 07:24 AM
    MERCEDES-BENZ E320 CDi Avantgarde HELP adam01 W210 E-Class 2 12-09-2007 05:40 PM
    Need single tip muffler with a nice tone, is Eisenmann the answer? doraemon R170 SLK-Class 10 09-20-2001 12:32 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome